Triumph 675 Forums banner
1 - 12 of 12 Posts

· Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
Hey guys,

Went for a ride the other day and noticed a strange whistle when I change gears, think for a BOV on a turbo. Accelerate, clutch in *blow off noise*

Bike rides fine and no issues other than this. Have never heard it before. Could the clutch plates/basket be making this noise?

It isn't the usual whistle sound when accelerating at all.
 

· Registered
Joined
·
148 Posts
Discussion Starter · #3 ·
Sound clip would help.

Sent from my iPhone using Tapatalk
Yeah, I don't have a GoPro anymore. May be able to put phone on ram mount and record.

Acceleration in normal, almost sounds like a belt whine but when I clutch in to change gear it sounds like a blow off valve.

Accelerate, clutch it *zuutuu* gear change.
 

· Registered
Joined
·
148 Posts
Discussion Starter · #4 ·
Okay, so I did some more riding.

Seems to happen around 4000rpm - I've done some google searches and seems like a similar symptom to the D675 flapper where they change it to 900rpm in TuneECU, however I don't believe our S3R's have that?

Nothing above/below that RPM makes the noise, all gears and neutral if I hold it at about 4-4.5rpm there is a whine/whistle type sound.
 

· Registered
Joined
·
148 Posts
Discussion Starter · #5 ·
Fixed!

So I took the tank off to check airbox / clean filter. Saw the plug from the stator melted.

Stripped/soldered new plug, and no more whine noise at 4k.
 

Attachments

  • Like
Reactions: mpusch

· Registered
Joined
·
148 Posts
Discussion Starter · #7 ·
Glad you got it fixed. Nice to have a documented resolution to an issue as well.
That's it! I'm glad it's fixed too. Guessing for some reason it was a resonance or something from the Stator. Who knows.

I extended the wire too from Stator > R/R and it sits more under the seat, the wire's still get quite hot though.
 

· Registered
Joined
·
357 Posts
Fixed!

So I took the tank off to check airbox / clean filter. Saw the plug from the stator melted.

Stripped/soldered new plug, and no more whine noise at 4k.
🏿I just replaced my stator & R/R, had them solder on a longer cable to run it directly to my R/R and they gave me a heavier duty connectors back in September.

Just noticed the sound after letting my bike sit since Thanksgiving. Your post help me to narrow down the noise. It is coming from the stator. I haven't checked the connections yet because I don't want to deal with this again.😫

I appreciate the post
 

· Registered
Joined
·
148 Posts
Discussion Starter · #9 ·
🏿I just replaced my stator & R/R, had them solder on a longer cable to run it directly to my R/R and they gave me a heavier duty connectors back in September.

Just noticed the sound after letting my bike sit since Thanksgiving. Your post help me to narrow down the noise. It is coming from the stator. I haven't checked the connections yet because I don't want to deal with this again.😫

I appreciate the post
Damn dude. Well at least you know where to start looking. :)
 

· Registered
Joined
·
357 Posts
🏿I just replaced my stator & R/R, had them solder on a longer cable to run it directly to my R/R and they gave me a heavier duty connectors back in September.

Just noticed the sound after letting my bike sit since Thanksgiving. Your post help me to narrow down the noise. It is coming from the stator. I haven't checked the connections yet because I don't want to deal with this again.😫

I appreciate the post
Damn dude. Well at least you know where to start looking. :)
😫😫😫😫😫Yup same issue with mine. It's any easy fix I just have to cut out the burned wires and crimp on new connectors. I think I'm going to sell her instead! I'm done
 

· Registered
Joined
·
148 Posts
Discussion Starter · #11 ·
😫😫😫😫😫Yup same issue with mine. It's any easy fix I just have to cut out the burned wires and crimp on new connectors. I think I'm going to sell her instead! I'm done
As much as I love my S3R, I'm feeling the same.

Need to replace the rad hoses and clamps now, fun fun.

For a 2012 model, I've needed to put more work into it than my 03 600RR I had, feeling the same about selling it.
 

· Registered
Joined
·
357 Posts
As much as I love my S3R, I'm feeling the same.

Need to replace the rad hoses and clamps now, fun fun.

For a 2012 model, I've needed to put more work into it than my 03 600RR I had, feeling the same about selling it.
Im just being a big baby, I have been working on this bike since I bought all mods and basic maintenance. So now that something that has failed I'm crying wolf saying the bike is junk when its not lol!.

I had 1 bad month in August 2018, My CPS went out, then found out my ZAF is not a replacement Oxygen sensor while pulling the header off to weld in a stock 02 Bung 1 of the exhaust studs came out of the block and at the same time I poked a hole in the radiator, then while pulling out the radiatior I put a hole in a hose. After getting all back together a week later my R/R harness melted and bike started smoking. After that horrible month Im no longer eager to put a wrench to my bike like I use to.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top