Triumph 675 Forums banner

1 - 20 of 9358 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter #1
just like the title states, what did u do to your 675 today?


I rode mine to pick up a gel passenger seat, then installed front and rear brakes, and polished/waxed the paint
 

·
Registered
Joined
·
2,428 Posts
I flushed out and then re-filled the brake fluid in my rear resevoir, changed the oil, test rode her to make sure the brakes were right and cycle the fresh Mobil 1 T, re-installed my camera mount on the gas cap for my ride to OC, MD tomorrow, plugged in my battery tender, wiped her down and said "see you tomorrow lover." It's been raining here all day so I figured I get some minor maintenance done since I wouldn't be doing any riding.
 

·
Registered
Joined
·
862 Posts
Met up with my buddy who has an R1 Special Edition and cruised around for about 70 miles. Now I am trying to figure out a way to make a fender kit without spending $100. I would like to keep the stock bracket and turn signals just move it around a bit so it does not look as unattractive.

Any suggestions?
 
  • Like
Reactions: Sammy901

·
Registered
Joined
·
3,464 Posts
Stared at it for a little bit in the garage--In 7 days it'll have a new home in Utah.
 

·
Registered
Joined
·
3,464 Posts
I flushed out and then re-filled the brake fluid in my rear resevoir, changed the oil, test rode her to make sure the brakes were right and cycle the fresh Mobil 1 T, re-installed my camera mount on the gas cap for my ride to OC, MD tomorrow, plugged in my battery tender, wiped her down and said "see you tomorrow lover." It's been raining here all day so I figured I get some minor maintenance done since I wouldn't be doing any riding.
Wave to the Rent A Cops--Err Seasonal Police Officers---I was one of them back in 1990 & 1991--Lived right next to Secrets when it was a small kick ass beach bar.
 

·
Registered
Joined
·
565 Posts
I drove the truck today. Still waiting for my oil to come in the mail...*sigh* Triumph is switching from Mobile 1 to castrol and I REFUSE to use that poop.
 

·
Registered
Joined
·
348 Posts
Changed the rectifier to an aftermarket one......spent 2 hours taking off the rear wheel, seat, tank and shock to get to it.......put it all back together and put the dry wheels back in ready for the California Superbike School at Silverstone next week..........

Tomorrow will be dialling the dry settings back in and loading it on the trailer
 

·
Registered
Joined
·
89 Posts
Nada today. My meds made a little sick so I missed a ride in the canyons. Yesterday I picked up some Frog Toggs rain gear and a battery tender for when my USB to ECU cable comes in. I'm still waiting for my Arrow slip on and rear sets.
 

·
Registered
Joined
·
4,464 Posts
Stared at it because I'm waiting for my connectors to come in from Eastern Beaver. If I had known it was going to take this long for those damn things to come in I would have just had decosse hook things up! I've stared at her for the past 2 weeks. :tissue:
 

·
Registered
Joined
·
249 Posts
Going for a ride here about 630 or so!
 

·
Registered
Joined
·
5,462 Posts
Nothing today. (It's 8am)

But yesterday I met up with a mate on a ZX/10R and we hit the hills. Rode the wheels off both bikes on The Creek Run - a winding ribbon of road that follows a creek through the Mt Lofty Ranges. It's out personal TT.

Wound up through Lobethal, back down the hill, ground the sliders at Photo Corner and then on to the Mad Mile. Crossed up wheelies over The Crest followed by a late lunch at The Cudlee Cafe.

Then on up Fox Creek Road and towards Ashton on some of the best twisty roads...more 'responsible' TT action through Castle Curves, then carved up Marble Hill Road. Mid-winter bliss.

Almost froze our arses off, but roads were dry and barely a car in sight. Zero traffic lights from go to whoah. Joy!



O.B
 

·
Registered
Joined
·
212 Posts
Found out the cable from the exup valve snapped :( I heard a loud pop yesterday when I turned it on going to my girl's house last night. Walked around it and found nothing but I had to go... so I left and the CEL was on. Turned it on today and heard the little valve motor several times and found the wire for the exup valve snapped :( I've heard of people talk of this but never read any of the threads. Thought the threads were about something that could be fixed after exup valve problem occurred. Not that the cable snapped and to do preventive maintenance on it b4 it happened (still haven't read those threads hehe). Oh well, time to take the valve and cat off :)
 

·
Registered
Joined
·
502 Posts
Rode to church. Rode to work. At work, not working. Thinking of where I am going to ride after work. Ugh.
 
1 - 20 of 9358 Posts
Top