Triumph 675 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
So I have a 2007 triumph Daytona and this weird ticking noise started the other day when I was driving on the highway. The sound sounds like its coming from the right side of the motor and starts around 6k rpm and gets faster as the rpms go up. I tried to pull the clutch in as I was cruising around 70 mph and gave it a rev and the ticking clicking sound came right as the rpms hit 6k. I noticed also that this sound comes and goes and sometimes it's loud and sometimes a little quieter and other days the sound is not there at all. I took the bike into the dealer and my tech rode it and said it was a loose chain and he tightened it but the sound is still there. I've read a lot of posts about valve noise but I'm not sure that this is related to that because I just had my 12k service done 600 miles ago and my valves were in spec. Also it sounds like its coming from the clutch. When I took the oil cap off and pulled in the clutch the middle plate seems to stick to the 3rd one and then goes into place and if I pull it slower it sticks and does not seperate from the 3rd plate? If anyone has any idea what this could be please let me know because I have an appointment next Tuesday but as the bike is my only means of transport I am concerned because its been ticking for at least 2 weeks now.
 

·
Registered
Joined
·
2,435 Posts
How many miles on your bike? Sounds like the stock cam chain tensioner needs to be replaced with a manual one. Do a search on manual CCT you will find piles of threads on it. APE makes one that is about $50 bucks. Works great.
 
1 - 5 of 5 Posts
Top