Triumph 675 Forums banner
1 - 16 of 16 Posts

Registered
Joined
15 Posts
Discussion Starter · #1 ·
Hey I have a 07 trumph daytona 675 rectifier overcharge my battery burn up my ecu my button start won't work my fuel pump keep priming ..I get a ecu off ebay not the same year everything comes on I'm the dash but the check engine light keep blinking and the button start still won't work fuel pump still keep priming......

Anyone know wats wrong 馃槙 馃様
 

Registered
Joined
949 Posts
I may be wrong, but I remember reading that an 09-12 ecu will work on an 06-08 bike, but one or two wires in the connector need to be swapped. Any 06-08 will be plug/play though.
 

Registered
Joined
949 Posts
No to both questions. Ebay would be my best guess for an ecu, and you'll have to search which wire(s) need to be swapped as it's something I remember reading about but don't remember any details.
 

Registered
Joined
15 Posts
Discussion Starter · #8 ·
Ok ebay as it but it's for $400 and I have ecu different ecu from 09-12 that are work ....I really would just want to fine dem wiring to make it work ..so u don't remember we're u fine dem details
No to both questions. Ebay would be my best guess for an ecu, and you'll have to search which wire(s) need to be swapped as it's something I remember reading about but don't remember any details.
Thanks anyways bro
 

Registered
Joined
949 Posts
Sorry man, that's all the info I have.
 

Registered
Joined
949 Posts
No. My understanding from a vague memory is that you HAVE to switch those wires, then ot's plug and play.
 

Registered
Joined
949 Posts
Maybe? You'll have to do some searching.
 
1 - 16 of 16 Posts
Top