Triumph 675 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 · (Edited)
Hi,

For purpose of having being picked up on the wknd for a missing plate light & reflector I've had to put my original rear fender back on (even though i bought my st3r s/h with the tidy)

In connecting the indicator wiring hubby managed to get all connected, yet parker/tail lights are not working. The rear light goes on when the brakes are engaged yet not without?

Any ideas?

Also where are the rest of the fuses located? I know the main 30v is under the seat, but I've no idea where the rest are... I have a strange feeling they're under the tank, but would rather ask b4 removing...

Thanks

PS: Perhaps its the dogs breakfast wiring that the previous owner left me with...! Such a painful job :sad5:
 

·
Registered
Joined
·
6,232 Posts
Fuses are under the left infill panel in front of the bike ;)
 

·
Registered
Joined
·
6,232 Posts
Haahaha... there goes me with my not reading the whole post again... :p
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #5 ·
Thanks for that, yes it was a fuse :rant2: & yes near the airbox, yet I did get some help as have never taken the tank off b4! good thing as my rego plate light needed some fixing as it wasn't engaging the globe properly... All resolved, now ready to take the shovel off again & put on my sexy little fender eliminator WITH a reflector & plate light & additional indicators too just in case they don't like the integrated light i have :laugh:
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top