Triumph 675 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Going through new to me 2013 Daytona 675 and trying to sort out and fix the odd stuff done by prior owner. Can anyone tell me what this yellow harness is for? This is under the gas tank, leading towards under the seat. I did not have time to trace it more and didn't find anything based on quick research. Any help is appreciated.
 

Attachments

·
Registered
Joined
·
255 Posts
That looks like the exhaust servo motor plug.

It goes out from under the subframe and is supposed to connect to the servo multiplug in front of the rear shock.
You probably have an afternarket exhaust and the servo motor removed. Normally you would have an ESRM like servo buddy plugged in to avoid an FI light, or the previous owner has the system disabled altogether.

Check this out.

Loose Plug in front of the shock
https://r.tapatalk.com/shareLink/to...ead.php?t=250563&share_type=t&link_source=app

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
39 Posts
Not sure but the quickshifter Plug is also under there as well. No certain if its that one though
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
That looks like the exhaust servo motor plug.

It goes out from under the subframe and is supposed to connect to the servo multiplug in front of the rear shock.
You probably have an afternarket exhaust and the servo motor removed. Normally you would have an ESRM like servo buddy plugged in to avoid an FI light, or the previous owner has the system disabled altogether.

Check this out.

Loose Plug in front of the shock
https://r.tapatalk.com/shareLink/to...ead.php?t=250563&share_type=t&link_source=app

Sent from my iPhone using Tapatalk
Yep, this looks like it. There is a Coffman's slip on installed and I have a CEL. Thanks for sharing this link! I should have time to dig into it this weekend.
 
1 - 6 of 6 Posts
Top