Triumph 675 Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Good evening y’all so really quick bought a 07 truimph Tona and it overheats and bubble’s, afterward just starts to leak all the fluid through the expansion tank already took it to two people that know way more than me and they can’t figure it out. So I’m just losing money any ideas would really like some help here lol
 

·
Registered
Joined
·
3,333 Posts
Did you use the bleed screw when you filled up the radiator? It sounds to me like either there is air in the system or the radiator cap requires replacing. You need to really lay these bikes over on the side while running to get all the air out.
 

·
Registered
Joined
·
694 Posts
Remove the thermostat and see what happens.
 

·
Registered
Joined
·
741 Posts
The new thermostats flow more as compared to the Gen1 orig. Does it just overheat in traffic (slow/stopped) or also at freeway speeds. Is there white sand in your overflow bottle?
 

·
Registered
Joined
·
694 Posts
What do you mean remove it i bought a new one and still does the same.
I meant exactly that, remove it and run the engine to see what's happening when it's not there.
 

·
Registered
Joined
·
158 Posts
What color is your rad fluid? Does it look like it's ever been changed? From my experience there's a chance it's original and it could be the system is dirty and plugged. A good cleaning might do it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
The new thermostats flow more as compared to the Gen1 orig. Does it just overheat in traffic (slow/stopped) or also at freeway speeds. Is there white sand in your overflow bottle?
No stopped as well just takes a bit longer to heat up but I haven’t tried it on freeway speed due to it overheating before I even ride two blocks away from my house
 

·
Registered
Joined
·
158 Posts
If it's heating to the point of boiling over within a couple of blocks then I'd suspect your waterpump has packed it in.
 
1 - 13 of 13 Posts
Top