Triumph 675 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
Hey guys, so I recently bought a track bike from a RideSmart instructor here in Texas. It's a 2006 Daytona 675 (obviously, lol) and everything seemed fine until a few hours into riding it.

EDIT* just got off the phone with RaceWorx, the people that built the motor and they say check the fuel first. As far as the bike cutting out. So I'll go dump the fuel now.

1st problem:
My bike will stall out while downshifting from around 3 gear to 1st, seems as if it happens when the RPM's are low but if I rev and downshift it's fine. When I just pull the clutch in, let the RPM's settle, and start to downshift while braking, the bike turns off. No, my rear wheel does not lock up, clutch lever and cable are good and are fully engaged.

2nd problem:

So my R6 did this and it turned out to be a bad stator, this isn't the case.
I was riding it decently hard, just to get the feel for the bike and testing everything out before track days. All of a sudden it seems as if it stopped getting fuel and started sputtering once I would try to give it any throttle. Also, right before this happened I could hear a loud winding sound as I accelerate and it sounded as if it was something winding up and spinning freely as I shift or pull the clutch in. Previous owner says there was a race alternator installed so not sure if that might be it. Back to the problem.. so I pull over to the side of the road with some buddies and bike dies. I tried started it, giving it gas and as soon as RPM's settled, the bike died. It wouldn't stay on. After about 5 minutes of sitting everything was back to normal. I was able to ride home for about 30 minutes. It seemed as if the bike didn't enjoy going over 6k RPM so I cruised home. Everytime I'd go past 6k that winding sound came up again and sort of felt like it was going to give out again. I'm not entirely sure if this was normal before I noticed it because I had music on.

I got the battery tested under load at cycle gear, the battery is good. I also hooked up a multimeter to the battery and ran the bike above 6k RPM's to see if the stator was charging the batter, it's working as advertised. So I am not sure what caused the bike to die like this.

I'm going to test compression next, going to run to the store to rent a compression kit but wanted to post on here while I'm out and see if someone has some ideas.

My ideas from searching-
Compression
ECU / tune
Stepper motor

Here is the advertisement for the bike and what was done too it.
 

Attachments

·
Registered
Joined
·
3,333 Posts
I have a race alternator in my race bike and it wont run for more than 30 mins without fully recharging the battery. Can you pull the alternator cover off and check?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I have a race alternator in my race bike and it wont run for more than 30 mins without fully recharging the battery. Can you pull the alternator cover off and check?
It for sure has a race alternator. The previous owner (I've been speaking with him all day pertaining to the issue) and he says he hasn't had that problem since he had the recall on the rectifier fixed.
 

·
Registered
Joined
·
88 Posts
Sounds like a alternator issue. Have the alternator checked. Pull the wires off of the harness and check for burns or corrosion on the harness. If the alternator is making a whining noise then something is not correct in my opinion.

Did you check your regulator for voltage spikes/drops?
 

·
Registered
Joined
·
2 Posts
Hey guys, so I recently bought a track bike from a RideSmart instructor here in Texas. It's a 2006 Daytona 675 (obviously, lol) and everything seemed fine until a few hours into riding it.

EDIT* just got off the phone with RaceWorx, the people that built the motor and they say check the fuel first. As far as the bike cutting out. So I'll go dump the fuel now.

1st problem:
My bike will stall out while downshifting from around 3 gear to 1st, seems as if it happens when the RPM's are low but if I rev and downshift it's fine. When I just pull the clutch in, let the RPM's settle, and start to downshift while braking, the bike turns off. No, my rear wheel does not lock up, clutch lever and cable are good and are fully engaged.

2nd problem:
So my R6 did this and it turned out to be a bad stator, this isn't the case.
I was riding it decently hard, just to get the feel for the bike and testing everything out before track days. All of a sudden it seems as if it stopped getting fuel and started sputtering once I would try to give it any throttle. Also, right before this happened I could hear a loud winding sound as I accelerate and it sounded as if it was something winding up and spinning freely as I shift or pull the clutch in. Previous owner says there was a race alternator installed so not sure if that might be it. Back to the problem.. so I pull over to the side of the road with some buddies and bike dies. I tried started it, giving it gas and as soon as RPM's settled, the bike died. It wouldn't stay on. After about 5 minutes of sitting everything was back to normal. I was able to ride home for about 30 minutes. It seemed as if the bike didn't enjoy going over 6k RPM so I cruised home. Everytime I'd go past 6k that winding sound came up again and sort of felt like it was going to give out again. I'm not entirely sure if this was normal before I noticed it because I had music on.

I got the battery tested under load at cycle gear, the battery is good. I also hooked up a multimeter to the battery and ran the bike above 6k RPM's to see if the stator was charging the batter, it's working as advertised. So I am not sure what caused the bike to die like this.

I'm going to test compression next, going to run to the store to rent a compression kit but wanted to post on here while I'm out and see if someone has some ideas.

My ideas from searching-
Compression
ECU / tune
Stepper motor

Here is the advertisement for the bike and what was done too it.
I am having the same issue on my 06 675. Have you figured out why it was doing that
 
1 - 5 of 5 Posts
Top