Triumph 675 Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
does anyone know where this goes i found it under the tank. and my bike died last night in the middle of the road. Instrument lights and headlights become dim. bike run like crup and when i twisted the throttle wont rev or run as usual until it died. i.used a multimeter and the bike doesnt charge the battery. no wire connection was melted under the tank.
 

·
Registered
Joined
·
52 Posts
And the wires coming out of the white connector in the bottom of your picture look melted or at least in pretty bad shape.
 

·
Registered
Joined
·
96 Posts
thank you. it is the wire that coming from rectifier i noticed that.
The rectifier to stator plug degrades over time and will eventually melt. You will then get some scary smoke coming out from under your seat/gas tank. Then your bike will stop charging the battery, shortly after you'll stall and be stranded.

Best fix is to cut out the plugs and make solid connections, but you can also replace the plugs.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
The rectifier to stator plug degrades over time and will eventually melt. You will then get some scary smoke coming out from under your seat/gas tank. Then your bike will stop charging the battery, shortly after you'll stall and be stranded.

Best fix is to cut out the plugs and make solid connections, but you can also replace the plugs.
this is what it happened to me
 
1 - 8 of 8 Posts
Top