Triumph 675 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
hey guys, not sure what's going on with my 07' daytona.

pulled out the exhaust to cover in header wrap and thought i'd pull all the fairings off so i could give everything a good clean. put it all back together and turned it over and now the engine management light stays on.

thought i may have unclipped a harness plug but i've looked over the loom 3 times now and i cant find any thing odd.

any ideas guys ??

thanks in advance.
 

·
Registered
Joined
·
3,327 Posts
Big mistake, lol...

As I said elsewhere, TuneECU + ODB II cable are your friends ;)

You might have pinched a hose, too.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
ok ok we're getting somewhere man thanks, i gather a tuneECU and ODB II cable would be some kind of diagnostics tool ?, is that something i can get online ?
 

·
Registered
Joined
·
51 Posts
yeah look at the tuneecu posts on here (plenty of em) ive just done this to tune out my exup, the software can diagnose ur ecu showing warning codes so you know what the fault is, and can edit fuel maps and its all free apart from a £8 OBDII cable
 

·
Banned
Joined
·
365 Posts
If the bike sounds and, feels no diffrent.
Take the bike out and let the light go 3 heat cycles. If the problem is not serious it will go and hopefully stay away.
Sometime the intake/exhaust just needs some elbow grease to clean after being adjusted.
The light will get logged for when you get to/purchase a tuneboy, and it usually confirms it is small stuff.

This is not a solution, just my experience from running the daytona (you said you just got it right?)
 

·
Registered
Joined
·
4,464 Posts
Did you wrap from the headers all the way back? Maybe you didn't reconnect the EXUP properly, EXUP out of spec range or EXUP stuck! What I'm getting at is TAKE OFF THE EXUP! :) The 3 heat cycles will do the trick also if it's nothing serious but will only work if you've fixed whatever it was that set the CEL off.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #8 ·
thanks alot guys i appreciate all the input i've received.

i have only wrapped the last two sections of pipe, not the headers but i have seen mention of removing/tuning out the EXUP so today i will download tuneECU and i'll have a look for a cable aswell. i had a brief glance over your link don- it seems like a pretty good tuning/diagnostics platform. i'll also try running it for a while k473y and i'll post up all my results.

thanks again , i really appreciate all your help.
 

·
Registered
Joined
·
4,464 Posts
siezed exup...thanks again team.
Now take that thing off and you won't have to worry about it lighting a CEL again. :thumbup: Glad we could help!
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #13 ·
Was the wrap intended to reduce the heat on your thighs? If so, how much of a difference has it made?
yeah it gets pretty hot under there so thats why i wrapped it,i've found it somewhat more comfortable and i also found it sits more comfortably at higher rev's...i recommend it.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #15 ·
yeah i pulled it out and lubed the bearing which worked swell but i havent tuned it out...i know i should but i dont have an ODBII cable yet.
 
1 - 15 of 15 Posts
Top