Triumph 675 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
So, I've owned my 07 Daytona for about 2 months. Did the regulator mod and the bike was working beautifully. Couple days ago went to go to work and the bike wouldn't start ( sorry for the long post but I'm just trying to let you guys/girls know what I have and haven't done so far ). No click or anything. But the guages would cycle and everything. So I being a dumb ass took my buddies advance and jumped the bike with a car battery. And the bike started and I left for work. Well 10mins later the bike shut off. And the battery blew up. Fast forward 3 days later. New battery in and bike won't start or even prime. There is absolutely no click at all. So I check all my fuses ignition switch fuse was blown so I replace it and all the fuses but the 3 larger relays and the the single relay on the lower half. Bike still wouldn't start and my ignition fuse blew itself again. Checked stator and r/r and they are both fine. I have no idea where to go from here I took about my ignition switch and couldn't find anything obviously wrong. Checked my fuel pump lines to make sure they aren't crossing eachother ( which I got from another post ) and they weren't. So I'm honestly lost on what to do. Anything helps, so thank you!!
 

·
Registered
Joined
·
632 Posts
Jumping a bike with a car battery is no big deal, I've done it a few times with my Daytona without any issues. Jumping a car with a motorcycle battery, that's a different story.

When you turn the key, do you hear the fuel pump prime or any other noises and it simply won't start (just a click), or is the bike completely dead (no instrument cluster)?
 

·
Registered
Joined
·
632 Posts
Sorry, just reread your post. If you're blowing a fuse, then you have a short somewhere which also explains why your battery blew. The damage was done before you jumped the bike, not a result of jumping the bike.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
Sorry, just reread your post. If you're blowing a fuse, then you have a short somewhere which also explains why your battery blew. The damage was done before you jumped the bike, not a result of jumping the bike.
Ya so right now as the bike sits, it doesn't prime up or anything. There is no click when I start the bike also. I just don't know where to go from here. I've taken everything apart. I'm thinking the issue is in the ignition somewhere, but that doesn't explain why my bike won't prime up
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
Jumping a bike with a car battery is no big deal, I've done it a few times with my Daytona without any issues. Jumping a car with a motorcycle battery, that's a different story.

When you turn the key, do you hear the fuel pump prime or any other noises and it simply won't start (just a click), or is the bike completely dead (no instrument cluster)
Another thing, the instrument cluster works but not the gear indicator
 

·
Registered
Joined
·
409 Posts
Check the starter relay.
 
1 - 7 of 7 Posts
Top