Triumph 675 Forums banner
1 - 14 of 14 Posts

· Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
So I think my bike has a very slight/intermittent misfire at idle and low rpms.
My bike would be idling perfectly at 1250 and suddenly the rpm would drop and start bouncing/hunting around 1000. It only happens after the bike is up to temp.

Another thing I noticed while lubing the chain with the bike on a paddock and in 1st gear, the bike is very very jerky and noisy when I do that, which my other bikes don't. I think the tyre should be rotating at a stable speed. But it is very unstable. Which makes me think that it's a misfire.

I changed my spark plugs and it's fine like 30%.
 

· Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Try resetting adaptions using TuneECU or let the bike idle without touching the throttle until the fan kicks in.
Yes have done both of those multiple times. The idle is super stable. But suddenly starts bouncing around.

Then I ride for a bit come to a stop at a red light and the idle is stable. Then 30-60secs later the needle suddenly crashes from 1250 to 1000 and keeps bouncing.
 

· Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
Sounds like perhaps the idle stepper motor is out of spec or malfunctioning. You can remove it and replace it with a manual idle adjuster.
Thanks for the reply. The ism is in spec and working fine according to the mechanic. And even I checked the ism voltages via TUNEECU.


In this video there's a difference in sound when I'm below 2.5k rpm(non-uniform). The sound becomes completely smooth once it goes to 3k rpm. Is this normal?
To add to this, if I ride in this rev range, the bike is very jerky(on-off on-off kinda jerks).

The CEL is due to O2 sensor that I removed to check if this issue stays.
 

· Registered
3 Daytonas and a Tracer 900GT
Joined
·
199 Posts
Sounds completely normal to me, if a little low rpm at idle? You say on the RAT forum that you have an O2 bypass and Bazzaz installed. That surely opens up many more possibilities? Not sure what the factory idle rpm is? Anyone know?
 

· Registered
Joined
·
33 Posts
Discussion Starter · #10 ·
Sounds completely normal to me, if a little low rpm at idle? You say on the RAT forum that you have an O2 bypass and Bazzaz installed. That surely opens up many more possibilities? Not sure what the factory idle rpm is? Anyone know?
The target is 1250. And its rock solid most of the time.
I've tried with and without the O2 eliminator. Removed the O2 altogether using tuneecu
Also tried with and without the bazzaz map. Tried richening the idle rpm cell in bazzaz too.
 

· Registered
3 Daytonas and a Tracer 900GT
Joined
·
199 Posts
Hmm ok. I still think it sounds pretty normal. Mine fluctuates slightly when warming up. The ECU will be fine tuning things continuously during warm up. Would be interesting to get 20 vids from other owners and compare. I think most vehicles generally will fluctuate a little during warm up. Just my opinion..
 

· Registered
Joined
·
33 Posts
Discussion Starter · #12 ·
Hmm ok. I still think it sounds pretty normal. Mine fluctuates slightly when warming up. The ECU will be fine tuning things continuously during warm up. Would be interesting to get 20 vids from other owners and compare. I think most vehicles generally will fluctuate a little during warm up. Just my opinion..
Yeah I searched youtube thoroughly for all videos just to get a glimpse of this. But in all videos, whenever the bike would be idling, it would be rock solid at 1250.

Mine is stable "during" warmup, starts acting up after getting to operating temp
 

· Registered
Joined
·
33 Posts
Discussion Starter · #14 ·
It seems fine. I think you're over thinking it. Just ride it.
So I just installed new coils as well. The symptom remained the same.
Since I don't have an O2 sensor/eliminator connected anymore. I have to manually add 25% trim in the 1k and 1.5k rpm zone via bazzaz. The issue seems better.

Could it be that there is a slight vacuum leak, which requires me to add so much extra fuel at idle so as to idle uniformly?
What are the symptoms of a vacuum leak?
 
1 - 14 of 14 Posts
Top