Triumph 675 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
Well what can I say. I'm a triple owner since Sep 17 2019. It was listed on letgo for a while as a no start and seemed like it was dropped due to engine cover damage. It was owner by a police officer who was learning to ride and dropped it a few times so he replaced what broke during drops (levers, fairings, etc) and never rode again (so it sat for 2 years). I got there and started the bike within 2 mins. The clutch lever was adjusted to "1" so I felt no resistance, put it to 5 and boom she fired right up. Front tire was still stock diablo supercorsa and rear was changed. Inspected the entire frame, steering stop, engine, tested electrical system, all fluids, etc. Offered a price and purchased it right there.

Unfortunately there is some work I would love to do to bring her back to her beauty again. So I'm still on lookout for all fairings from a 2011 (except the left side, scored that a week ago). The ignition wires has also been cut and rejoined with butt connectors (owner said his buddy tried to diagnose the no start issue and did that) so will solder that back up over the winter and refresh the fork oil, all fluids.

There were 3900 miles on odometer when I got her. Now she has 4500 without any problems. Just put on Michelin power rs tires and man coming from my first bike, sv650, this thing is exuberant.

Anyone else from Pennsylvania, USA?



Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
8,110 Posts
.... The ignition wires has also been cut and rejoined with butt connectors (owner said his buddy tried to diagnose the no start issue and did that)...
Ugh...... I wonder WTF he thought he would find by doing that? And then to find out it was the stupid clutch lever adjustment. lol

Anyhow, SE model is a good find, love the blue frame on those. Lots of good folk here that'll share the knowledge. :smile2:
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
Ugh...... I wonder WTF he thought he would find by doing that? And then to find out it was the stupid clutch lever adjustment. lol

Anyhow, SE model is a good find, love the blue frame on those. Lots of good folk here that'll share the knowledge. :smile2:
Apparently he also owns a small bike shop. I would be disappointed as a customer if you hacked my wires up and couldnt figure anything out.

Nonetheless I'm happy I was the first one there and offered him 3k. Ofcourse I have already spent 1k on mods, and probably another 1k just to get it back to stock. Got rid of cheap levers and took off all cheap aftermarket shit that might kill you, added a quickshifter (bought from this forum), 2 bro exhaust (surprisingly the stock exhaust sounded pretty loud as well), all turn signals were missing so added motodynamic tail light and flush turn signals.

I have realized my sv650 is pretty stable in 1st gear riding at idle speed (without any throttle input) but the 675 is jerky at the same (1st gear without throttle). Friends tell me its normal for a bike with that power but I practice slow speed maneuvers and that might make it very difficult on the daytona.

Sent from my SM-G950U using Tapatalk
 
1 - 3 of 3 Posts
Top