Triumph 675 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey I have an 08 675 and was riding on the freeway when my timing chain seemed to have stretched. I got some chain rattle and trailered the bike home tightened up my manual tensioner and the rattle went away. But now the bike has almost no power above 6k rpms. Everything sounds and seems okay besides a hot start issue I beleive is my starter solenoid. Anyone experinaced this before? I'm thinking maybe low fuel pressure? Havent had time to dig into it yet.
 

·
Registered
Joined
·
868 Posts
Hey I have an 08 675 and was riding on the freeway when my timing chain seemed to have stretched. I got some chain rattle and trailered the bike home tightened up my manual tensioner and the rattle went away. But now the bike has almost no power above 6k rpms. Everything sounds and seems okay besides a hot start issue I beleive is my starter solenoid. Anyone experinaced this before? I'm thinking maybe low fuel pressure? Havent had time to dig into it yet.
Such drastic reduction in power might mean the chain has skipped one or two teeth. Maybe it's best you check cam/crank alignment and see if it solves the problem.
 

·
Registered
Joined
·
868 Posts
I remember MacBandit's bike was one tooth off from spec on one of the cams, from the factory. So I guess 1 or maybe even 2 teeth will not destroy your engine, but it probably depends on which cam and the direction of the skip.



Whatever the case, since you had this cam chain/tensioner occurrence, that's where I'd start from.
 
1 - 9 of 9 Posts
Top