Triumph 675 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all. I'm new to this forum and new to owning a Triumph. I bought the bike with a wrecked front end, and I've replaced the frame, front forks, triple tree, and the wiring harness. The wiring harness was trashed in the crash, so I found one on Ebay. Turns out it was an 08 harness, and my bike is 07.

Apparently, some changes were made with
the fuel pump relay deal. I've found a bunch of different forums talking about it, but I can't seem to piece it all together. From what I've read, it seems that in 07 models, a sub-harness was added that would connect into the existing fuel pump connector and exhaust flapper connector and send the power down to a relay. However, in the 08 harness that I have, the relay is already built-in. I think in 2008 the ECU sends out power for the fuel pump on a different pin as well.

I pulled out the add-on relay from the old 07 harness when I put the new one in, but I still don't think I have any power to the fuel pump. I obviously need to poke around with a multimeter and find where I do or don't have power.

I haven't been able to find a 2008 wiring diagram. I'm hoping someone here can post a 2008 diagram and let me know what changed on the ECU connections. I think I need to move the fuel pump wire on the new harness to a different pin, I believe B29, when it is on B36? Has anyone had a similar problem or dealt with this relay change? Thanks!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your help! After looking into it a bit more, I found that the relay stuff was a red herring. All it was was the fuel pump. I was able to ride it last night!
 
1 - 3 of 3 Posts
Top