Triumph 675 Forums banner

troubleshooting

  1. General 675 discussion
    So, just recently got the bike. Everything looked in great condition. Rode it 2 hours back to my place. For 4 days the bike worked perfectly. Had a slow start 1 morning but that was it. Then after riding for about 30 minutes, stopped to get something to eat, came back out to start the bike and...
  2. Maintenance and repair
    I recently purchased an 08 675 with roughly 6000 miles on it and drove it back to Fort Worth from New Orleans with no problems at all. Just recently I began noticing a faint clicking sound coming from the front end while riding. The best way to describe this sound would be similar to putting a...
  3. Maintenance and repair
    I have a 2005 Daytona 650 and I'm having some issues with what I think my be my rectifier or alternator. The symptoms my bike is displaying are as follows. - trouble starting on the first time usually takes 2 or three for it to turn over unless I just removed it from the battery tender. - the...
  4. Repair/Troubleshooting
    Wondering if anyone has seen or had this issue with their shifter. Last week I took off in the morning to go to work, got to the end of my street, and coming up to the stop sign I tried to click down through the gears from 4 to 1, but it would not shift down, no matter how many times I hit the...
  5. Repair/Troubleshooting
    So after just finishing taking the bike apart, tank off, installed some new electrics, rear block sliders, coating everything in ACF50 for protection etc and then putting everything back together (no left over parts, which is good). I go to turn the bike on, and the console is dead, no startup...
Top