New tail light unit won't hold in place - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 2 Old 06-16-20, 03:01 Thread Starter
HolaBlondie
Junior Member
 
HolaBlondie's Avatar
 
Join Date: May 2020
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
New tail light unit won't hold in place

Good morning
I am having an issue with my Street and I hope someone could give me some help/advice.
Yesterday I replaced my stock red tail light with the OEM clear one.
The disassembly of the stock unit went easy as well as the replacement of the tail light itself.
I put back the unit and torqued the screws to specs and I noticed the unit doesn't adhere steadily to the subframe, but it has some play.
I unscrewed the unit, substitute the clear light with the stock red and put back the unit in the motorcycle, same issue, the unit has lots of play.
So I disassembled my boyfriend's motorcycle tail light (he has my same model) and in his, the light was fitting perfectly.
The only difference between our motorcycles are:
  • Tail tidy - He has the new evotech, I have an old one
  • Undertray - He has the one for the passenger handles and I don't

(Motorcycle is a 2013 Street Triple)

Thank you in advance!!
Attached Thumbnails
Click image for larger version

Name:	104173535_3168943363164448_3416775338004248891_n.jpg
Views:	31
Size:	90.2 KB
ID:	252809  

__________________________________

When in doubt, throttle out
HolaBlondie is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-23-20, 15:52
anacron08
Junior Member
 
Join Date: Oct 2013
Location: Washington DC
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Could the tail tidy/tail light wires be getting in the way and putting pressure on the tail light housing/undertray?


I'd also compare the tail light housing between the two bikes and see if something's up with yours.
anacron08 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
street triple 675 , tail light

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome