3rd gen Daytona R shifting 3rd to 4th issue - Triumph675.Net Forums
Maintenance and repair Problems, fixes, general maintenance talk

 
Thread Tools Display Modes
post #1 of 5 Old 12-03-19, 02:41 Thread Starter
Aglareinmyeyes
Junior Member
 
Join Date: Sep 2016
Location: Los Angeles
Posts: 84
Thanks: 2
Thanked 0 Times in 0 Posts
3rd gen Daytona R shifting 3rd to 4th issue

2013+ Daytona 675R 12k-ish miles
Bazzaz QS
Attack Performance rear sets
GP shift
Track bike (only)
Just did an oil change before the last track day. Oil was still in pretty good visual condition. Didn't notice any obvious metal bits when I drained it.

On the straights under wide open throttle I'm missing shifts between 3rd and 4th gear. It will fall into neutral (between 3/4). I'm using the same amount of firm shift lever pressure that I've been using for the 3 years I've had the bike. Thought for a minute maybe I was being too gentle but even being really firm created the same result. The only exception being that it sometimes "clunked" and actually grabbed 5th gear

I retightened all the linkage and everything feels nice and snug. No slop in the shift lever action.

Talked with Bazzaz and they didn't seem to think it was a QS issue.

I'm getting ready to open up the clutch side and visually inspect things.

Anything in particular (besides big chunks of metal) I should be looking for or looking at?

Is this a common issue with a common fix?

Special tools needed?

I have fairly good mechanical skills and room to work so I'd like to tackle this myself if possible. My Triumph mechanic is dealing with a shoulder surgery and won't be able to look at it for at least a few months.
Aglareinmyeyes is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-03-19, 08:37
905
Junior Member
 
Join Date: Jun 2016
Posts: 18
Thanks: 14
Thanked 0 Times in 0 Posts
There was a star shift update. I had 2 2014 Daytona’s and one had it done right away the other was the wife’s and I never rode it till last year. Once I changed that no issue with shifting at wide open throttle.


Sent from my iPhone using Tapatalk
905 is offline  
post #3 of 5 Old 12-04-19, 19:33 Thread Starter
Aglareinmyeyes
Junior Member
Threadstarter Threadstarter
 
Join Date: Sep 2016
Location: Los Angeles
Posts: 84
Thanks: 2
Thanked 0 Times in 0 Posts
Were you having that same 3rd/4th issue? Did those bikes have quickshifters?
Aglareinmyeyes is offline  
 
post #4 of 5 Old 12-07-19, 09:48
905
Junior Member
 
Join Date: Jun 2016
Posts: 18
Thanks: 14
Thanked 0 Times in 0 Posts
Yes both bikes have QS and it was 3-4 and 4-5


Sent from my iPhone using Tapatalk
905 is offline  
post #5 of 5 Old 12-10-19, 15:49
WarrenM
Junior Member
 
Join Date: Sep 2013
Location: Johannesburg
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Had exact same issue on my 15 with 11k on the clock. it’s not a QS issue. On my bike it turned out to be the detent wheel which had worn/rounded edges on it. The dealer decided to change the selector arms, drum and shaft while it was open with the updated parts but the cause seems to have been a worn detent wheel.

A friend who raced his bike said they kept a few extras handy because the detent wheels would either wear down or break the teeth on it.
WarrenM is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome