Daytona 2006 Rev counter issue - Triumph675.Net Forums
Maintenance and repair Problems, fixes, general maintenance talk

 
Thread Tools Display Modes
post #1 of 2 Old 11-08-20, 12:05 Thread Starter
Max67594
Junior Member
 
Join Date: Nov 2020
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Daytona 2006 Rev counter issue

Hi,
Could someone please tell me why this is happening on my rev counter? The EML is also on after start up.

TIA
Max67594 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-08-20, 12:06 Thread Starter
Max67594
Junior Member
Threadstarter Threadstarter
 
Join Date: Nov 2020
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Photo below
Attached Thumbnails
Click image for larger version

Name:	88DFB642-6FE8-468F-AFBE-E93DB94C2838_1604851581516.jpg
Views:	34
Size:	114.2 KB
ID:	253689  
Max67594 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome