Bike stalls when placed into gear - Triumph675.Net Forums
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

 
Thread Tools Display Modes
post #1 of 2 Old 11-16-20, 03:34 Thread Starter
xetegugi
Junior Member
 
Join Date: Nov 2020
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Bike stalls when placed into gear

Bike starts fine, idles fine, revs fine but shuts off when I place it in gear. Thoughts?

xetegugi is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-16-20, 06:18
rokerr
Junior Member
 
Join Date: Mar 2018
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Bad kickstand switch? Thinks itís down and wonít stay running


Sent from my iPhone using Tapatalk
rokerr is offline  
The Following User Says Thank You to rokerr For This Useful Post:
NewYork (11-16-20)
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome