Headlights not working - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 2 Old 09-27-20, 12:01 Thread Starter
Bigtimecc
Junior Member
 
Join Date: Sep 2020
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Headlights not working

I have a 2007 Daytona Triple and last night my headlights stopped working. Bulbs aren’t blown, fuse is good. The high beam indicator is stuck on but there’s no lights. When I remove the H9 bulb the indicator goes off. I’ve put in new bulbs and fuses just in case and I still do not have light. I’m lost now does anyone have any suggestions on what else I should check?
Bigtimecc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-28-20, 07:20
Chirp
Member
 
Join Date: Nov 2011
Location: Southeastern PA
Posts: 396
Thanks: 1
Thanked 24 Times in 23 Posts
Electrical gremlins are the worst to diagnose. The proper way to do this is to sit down with the wiring diagram and a pencil and trace all the pathways to and from the bulb, switch, etc. Budget 3 hours. That said, I'd start by spending $20 and replace the relay and double check all the multi-connectors I could reach. And maybe spray WD40 on the high/low switch and toggle it it back and forth for a while.

'61 Clubman's Gold Star, '13 Duke 690, '13 Daytona 675R (track bike), '18 Street Triple RS, '20 R1250R
Chirp is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome