09 D675, intermittent no power to dash/no start. - Triumph675.Net Forums
Maintenance and repair Problems, fixes, general maintenance talk

 
Thread Tools Display Modes
post #1 of 3 Old 03-10-20, 21:20 Thread Starter
divune
Junior Member
 
Join Date: Oct 2017
Posts: 11
Thanks: 4
Thanked 0 Times in 0 Posts
09 D675, intermittent no power to dash/no start.

Hi all. My 09 Daytona 675 has recently developed an issue where upon key on, the dash will not power up, nor does the pump and etc prime. The turn signals and brake lights will work in this position, just no dash and will not start. Usually waiting 10 minutes or so it will resolve.
I have the r/r upgraded with the newer triumph part & adapter harness, and the battery is 1 year old along with it. Charges fine ~14v, and the battery holds voltage as well. I've gone through all the connectors as well as the ones behind the dash with no improvement. Any specific items anyone may know of causing this?
divune is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-10-20, 21:39
subaruzi
Junior Member
 
subaruzi's Avatar
 
Join Date: Aug 2019
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
Kill switch faulty?

That happened to mine.

Sent from my moto x4 using Tapatalk
subaruzi is offline  
post #3 of 3 Old 03-11-20, 11:25
ramnakhle
Member
 
ramnakhle's Avatar
 
Join Date: Jul 2016
Location: Beirut
Posts: 201
Thanks: 51
Thanked 20 Times in 18 Posts
Garage
Check your wiring and harnesses for any kinks.
Also try to move the handle bars left/right with the key on and see if it affects anything.

I recently had a problem where everything is normal on dash, and if I hit the starter switch nothing happened unless I turned the handle bars to the left.
Turned out to be a kink in a mis-routed harness resulting in a cut wire. The ends would come together when I turned the handle bars and make contact to start the bike.



Soldered



Shielded




Fixed
ramnakhle is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome