Rough idle - Triumph675.Net Forums
Maintenance and repair Problems, fixes, general maintenance talk

 
Thread Tools Display Modes
post #1 of 3 Old 09-26-19, 20:59 Thread Starter
isuxela01
Junior Member
 
Join Date: Sep 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rough idle

2013 Daytona 675R

There are a couple things going on that i think are all related to the same problem

-when i start bike, fuel guage does not display near correct qquantity or will say that there is no fuel in the tank. (has been fixing itself as i start riding for a few minutes)
-rough and low idle (500-750 rpm) will occasionally die after start up but not always
-check engine light is on (don't know the code)
-bike is due for its 12,000 mile service (just want to put that out in case someone thinks that there can be a fault from that.
-the bike had been sitting with no fuel for about 4 weeks

I'm focused primarily on trying to troubleshoot the idling problem
isuxela01 is offline  
Sponsored Links
Advertisement
 
 

Bookmarks

Tags
ecu , engine light , engine management system , idle

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Threaded Mode Threaded Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome