Valve clatter on startup - Page 2 - Triumph675.Net Forums
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

Reply
 
Thread Tools Display Modes
post #11 of 12 Old 08-02-16, 21:57
MotoMeets
Member
 
MotoMeets's Avatar
 
Join Date: Oct 2014
Posts: 341
Thanks: 9
Thanked 17 Times in 15 Posts
Garage
Quote:
Originally Posted by RidersDiscount View Post
Fixed it for you
Quote:
Originally Posted by MotoMeets View Post
Gee thanks.
I believe I owe you an apology @RidersDiscount . I read your quote as a grammar nazi correction of "Daytonas". So, sorry <3



Find Your Ride - https://www.motomeets.com/
MotoMeets is offline  
Sponsored Links
Advertisement
 
post #12 of 12 Old 08-03-16, 11:40
RidersDiscount
Platinum Site Sponsor
 
RidersDiscount's Avatar
 
Join Date: Oct 2009
Location: Riders Discount
Posts: 13,025
Thanks: 89
Thanked 304 Times in 247 Posts
No worries

Call TJ at 866-931-6644 ext 817. Our business hours are Monday-Friday 9:30AM-6PM EST. Visit our website at Riders Discount.

Facebook Twitter Instagram YouTube
RidersDiscount is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome