Battery blew up and bike won't start with new one. - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 7 Old 09-13-19, 03:47 Thread Starter
DayT675
Junior Member
 
Join Date: Aug 2019
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Battery blew up and bike won't start with new one.

So, I've owned my 07 Daytona for about 2 months. Did the regulator mod and the bike was working beautifully. Couple days ago went to go to work and the bike wouldn't start ( sorry for the long post but I'm just trying to let you guys/girls know what I have and haven't done so far ). No click or anything. But the guages would cycle and everything. So I being a dumb ass took my buddies advance and jumped the bike with a car battery. And the bike started and I left for work. Well 10mins later the bike shut off. And the battery blew up. Fast forward 3 days later. New battery in and bike won't start or even prime. There is absolutely no click at all. So I check all my fuses ignition switch fuse was blown so I replace it and all the fuses but the 3 larger relays and the the single relay on the lower half. Bike still wouldn't start and my ignition fuse blew itself again. Checked stator and r/r and they are both fine. I have no idea where to go from here I took about my ignition switch and couldn't find anything obviously wrong. Checked my fuel pump lines to make sure they aren't crossing eachother ( which I got from another post ) and they weren't. So I'm honestly lost on what to do. Anything helps, so thank you!!
DayT675 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 09-13-19, 15:00 Thread Starter
DayT675
Junior Member
Threadstarter Threadstarter
 
Join Date: Aug 2019
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Any help or inputs would be greatly appreciated
DayT675 is offline  
post #3 of 7 Old 09-13-19, 21:30
Renboy
Member
 
Renboy's Avatar
 
Join Date: Mar 2013
Location: Guelph
Posts: 471
Thanks: 8
Thanked 24 Times in 24 Posts
Garage
Jumping a bike with a car battery is no big deal, I've done it a few times with my Daytona without any issues. Jumping a car with a motorcycle battery, that's a different story.

When you turn the key, do you hear the fuel pump prime or any other noises and it simply won't start (just a click), or is the bike completely dead (no instrument cluster)?

The sooner you introduce motorcycles into your children's lives, the less likely they'll have money for drugs, alcohol and cigarettes as teenagers.
Renboy is offline  
 
post #4 of 7 Old 09-13-19, 21:32
Renboy
Member
 
Renboy's Avatar
 
Join Date: Mar 2013
Location: Guelph
Posts: 471
Thanks: 8
Thanked 24 Times in 24 Posts
Garage
Sorry, just reread your post. If you're blowing a fuse, then you have a short somewhere which also explains why your battery blew. The damage was done before you jumped the bike, not a result of jumping the bike.

The sooner you introduce motorcycles into your children's lives, the less likely they'll have money for drugs, alcohol and cigarettes as teenagers.
Renboy is offline  
post #5 of 7 Old 09-14-19, 14:43 Thread Starter
DayT675
Junior Member
Threadstarter Threadstarter
 
Join Date: Aug 2019
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Renboy View Post
Sorry, just reread your post. If you're blowing a fuse, then you have a short somewhere which also explains why your battery blew. The damage was done before you jumped the bike, not a result of jumping the bike.
Ya so right now as the bike sits, it doesn't prime up or anything. There is no click when I start the bike also. I just don't know where to go from here. I've taken everything apart. I'm thinking the issue is in the ignition somewhere, but that doesn't explain why my bike won't prime up
DayT675 is offline  
post #6 of 7 Old 09-14-19, 14:44 Thread Starter
DayT675
Junior Member
Threadstarter Threadstarter
 
Join Date: Aug 2019
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Renboy View Post
Jumping a bike with a car battery is no big deal, I've done it a few times with my Daytona without any issues. Jumping a car with a motorcycle battery, that's a different story.

When you turn the key, do you hear the fuel pump prime or any other noises and it simply won't start (just a click), or is the bike completely dead (no instrument cluster)
Another thing, the instrument cluster works but not the gear indicator
DayT675 is offline  
post #7 of 7 Old 09-15-19, 09:03
Chirp
Member
 
Join Date: Nov 2011
Location: Southeastern PA
Posts: 364
Thanks: 1
Thanked 22 Times in 21 Posts
Check the starter relay.

'61 Clubman's Gold Star, '13 Duke 690, '13 Daytona 675R (track bike), '17 Superduke GT, '18 Street Triple RS
Chirp is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome