Fuel Pump Salvageable? - Triumph675.Net Forums
Maintenance and repair Problems, fixes, general maintenance talk

 
Thread Tools Display Modes
post #1 of 6 Old 02-03-20, 11:28 Thread Starter
itsMeanMuggin
Junior Member
 
Join Date: Jan 2020
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Question Fuel Pump Salvageable?

I may just break down and buy a used one; but do you all think this is salvageable?

Also, the wiring is pretty brittle, which concerns me.
Attached Thumbnails
Click image for larger version

Name:	60237459021__856543DF-04C4-4685-B1D6-1EDDC7FC0696.jpg
Views:	36
Size:	280.0 KB
ID:	251815  
itsMeanMuggin is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-03-20, 11:32
subaruzi
Junior Member
 
subaruzi's Avatar
 
Join Date: Aug 2019
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
That's a disaster. I'd get new one and buy fresh filter for it

Sent from my moto x4 using Tapatalk
subaruzi is offline  
post #3 of 6 Old 02-03-20, 11:39 Thread Starter
itsMeanMuggin
Junior Member
Threadstarter Threadstarter
 
Join Date: Jan 2020
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by subaruzi View Post
That's a disaster. I'd get new one and buy fresh filter for it

Sent from my moto x4 using Tapatalk
You should see the tank
itsMeanMuggin is offline  
 
post #4 of 6 Old 02-03-20, 12:19
subaruzi
Junior Member
 
subaruzi's Avatar
 
Join Date: Aug 2019
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
I'm going through it now. Really frustrating. I found that you can put magnet in it and shake it to get all the flakes out. Rinsed with evapo-rust and seems to have cleaned it up decently

Sent from my moto x4 using Tapatalk
subaruzi is offline  
post #5 of 6 Old 02-03-20, 15:01 Thread Starter
itsMeanMuggin
Junior Member
Threadstarter Threadstarter
 
Join Date: Jan 2020
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
I used evapo-rust, let it set for a few hours, shaking it every hour. It did decent, the magnet would have been a good idea.
itsMeanMuggin is offline  
post #6 of 6 Old 02-05-20, 07:22
subaruzi
Junior Member
 
subaruzi's Avatar
 
Join Date: Aug 2019
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
What year was this from?

Sent from my moto x4 using Tapatalk
subaruzi is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome