2010 speedo - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 1 Old 04-09-20, 00:34 Thread Starter
Trevor Doig
Junior Member
 
Join Date: Apr 2020
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2010 speedo

Hi, been looking for ages and cant seem to find what I'm looking for.

I have a 2010 street and the speedo is a bit buggered... doesnt show the current speed as the person who had the bike before me put a screw that was to long to fix it to the bracket and I think I've shorted it when I took it off the other day. Theres also a tiny hole between 2 of the pins on the board.
I've attached some picture to show what I mean.

So my questions are....

Can I get it repaired or will it have to be a new cluster?

If it's a new cluster, where is the total mileage stored, on the cluster or ECU?

If total mileage is on the cluster, can I get it reset to what it actually is?

Thanks for any information or help!!

Trevor
Attached Thumbnails
Click image for larger version

Name:	20200408_170130_1586406765637.jpg
Views:	12
Size:	145.8 KB
ID:	252359   Click image for larger version

Name:	20200408_170128_1586406785339.jpg
Views:	11
Size:	149.4 KB
ID:	252361   Click image for larger version

Name:	20200408_171713_1586406805376.jpg
Views:	13
Size:	87.1 KB
ID:	252363   Click image for larger version

Name:	20200408_172210_1586406844369.jpg
Views:	11
Size:	65.0 KB
ID:	252365  
Trevor Doig is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome