Under seat electrics - Triumph675.Net Forums
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

 
Thread Tools Display Modes
post #1 of 3 Old 04-07-20, 23:23 Thread Starter
peterjs
Junior Member
 
Join Date: Mar 2020
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Under seat electrics

Hi, I found this picture in another forum and had a look under my seat, well I have the same thing and I have no idea just what it is, I am sure someone here will know. thanks, Pete
Attached Thumbnails
Click image for larger version

Name:	Daytona under seat.JPG
Views:	39
Size:	39.9 KB
ID:	252353  
peterjs is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-08-20, 02:24
MGFChapin
Senior Member
 
MGFChapin's Avatar
 
Join Date: Aug 2006
Location: Seattle
Posts: 7,748
Thanks: 82
Thanked 337 Times in 309 Posts
Garage
Alarm plug
MGFChapin is online now  
post #3 of 3 Old 04-08-20, 16:39 Thread Starter
peterjs
Junior Member
Threadstarter Threadstarter
 
Join Date: Mar 2020
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Thank you, was just not sure what it was. Pete
peterjs is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome