675 wont start - fuel issue or spark - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 2 Old 11-15-19, 07:17 Thread Starter
DerClown
Junior Member
 
Join Date: Jun 2013
Location: Turku
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
675 wont start - fuel issue or spark

Hi guys,

I hope you have the patience and time to help a novice brother out...

So I changed the bottom plate of the fuel pump, re-placed the black connector (yes you guessed right I dropped my tank).
I have also changed spark plugs and filter (reason I dropped the tank).

Now the bike wont start. Newly charged battery, jacked it for about 20-30 times and does not start.
The pump runs, and when turning the key and looking in the tank I can see bubbles around the pump.
There is around 1L of gas in the tank, but it should be enough since the bottom is completly covered.

1: What if the connector cabels are the wrong way, can the pump run the wrong way? or is it +/-? (black - black/green wires).
Sucking instead of umping...

2: can it just be the fuel connector is not perfectly connected? I pushed it in until I heard the click.

Is there an easy way to check if the pump is pumping gas, can I just remove the connector? I have the old white connector from the old bottom plate of the pump, if I can connect that and to a hose it should pump gas, correct?

If it's not fuel related, I guess I have missed something when changing the plugs...
DerClown is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-15-19, 09:42
Renboy
Member
 
Renboy's Avatar
 
Join Date: Mar 2013
Location: Guelph
Posts: 471
Thanks: 8
Thanked 24 Times in 24 Posts
Garage
If the bike ran fine before you changed the pump and plugs, and that's all you changed, then my guess is the hose from the pump is pinched.

The sooner you introduce motorcycles into your children's lives, the less likely they'll have money for drugs, alcohol and cigarettes as teenagers.
Renboy is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome