No spark - Triumph675.Net Forums
Maintenance and repair Problems, fixes, general maintenance talk

 
Thread Tools Display Modes
post #1 of 15 Old 05-21-19, 19:05 Thread Starter
apiazza
Junior Member
 
apiazza's Avatar
 
Join Date: Jul 2018
Posts: 67
Thanks: 5
Thanked 2 Times in 2 Posts
No spark

I was unloading the track bike from the trailer and ended up dropping it on the right side. Didnt think much of it, picked it up, put it away and went on with my day. Came back later, went to fire it up and the starter cranks strong but absolutely to ignition. Not even an attempt.

I pulled the air box found a bit of oil from the crank breather so I thought maybe wet plugs. Pulled them and cleaned them. I grounded the plug to the block to check for spark and had absolutely nothing. I'm guessing the drop rattled something but I just cant figure out what or where. Suggestions to look for? I just resolved the shifting issue and now this. I cant win.

Sent from my SM-G965U using Tapatalk
apiazza is offline  
Sponsored Links
Advertisement
 
 

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Threaded Mode Threaded Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome