Street Triple issue - Triumph675.Net Forums
Triumph675 Site Issues Got ideas on how to improve the site or having problems on the site? We'd like to hear about them.

 
Thread Tools Display Modes
post #1 of 2 Old 09-30-20, 22:27 Thread Starter
Miss pancakes
Junior Member
 
Miss pancakes's Avatar
 
Join Date: Sep 2020
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Street Triple issue

I went for a ride on the weekend. The bike suddenly stalled. I tried to start it but it wouldn’t turn over. Subsequently the gear indicator disappeared and I couldn’t change gears. After a few minutes gears reappeared and I could change them again. Although couldn’t start the bike.
After a while I tried to start the bike again and it started, although engine sounded out of sync as if only two cylinders were working. I switched it off.
After an hour waiting for a tow truck I tried again and bike started and sounded normal again. I was able to get home.
Now the bike makes a horrible noise.
https://youtu.be/35OXFNMWzuo
I had ignition wire replaced lately, stator fixed, major service done. Any ideas on what it is this?
Miss pancakes is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-01-20, 10:29
samwise_i
Member
 
Join Date: Jun 2006
Location: Norcal
Posts: 679
Thanks: 13
Thanked 19 Times in 17 Posts
Stator came loose would be my guess. Do not start it again until resolved.
samwise_i is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome