Oem vs Ricks stator - Page 5 - Triumph675.Net Forums
Reply
 
Thread Tools Display Modes
post #41 of 46 Old 03-18-17, 16:15
jb.junior
Member
 
jb.junior's Avatar
 
Join Date: May 2012
Location: Houston
Posts: 363
Thanks: 2
Thanked 10 Times in 8 Posts
Caltric stator does not fit in the Woodcraft stator cover. CPS cable is too short for it to reach its mounting spot.

Can anyone confirm whether or not a Rick's will fit in the Woodcraft cover?
jb.junior is offline  
Sponsored Links
Advertisement
 
post #42 of 46 Old 03-18-17, 18:24
Paul_E_D
Member
 
Paul_E_D's Avatar
 
Join Date: Sep 2013
Location: Hatfield
Posts: 718
Thanks: 3
Thanked 61 Times in 52 Posts
Yes, My rick's fit in my woodcraft cover

Paul_E_D
One on One Instructor
Paul_E_D is offline  
post #43 of 46 Old 03-18-17, 19:32
jb.junior
Member
 
jb.junior's Avatar
 
Join Date: May 2012
Location: Houston
Posts: 363
Thanks: 2
Thanked 10 Times in 8 Posts
Quote:
Originally Posted by Paul_E_D View Post
Yes, My rick's fit in my woodcraft cover
Thank you.
jb.junior is offline  
 
post #44 of 46 Old 03-19-17, 10:52
Glocken
Senior Member
 
Glocken's Avatar
 
Join Date: Sep 2011
Location: Brooklyn
Posts: 2,413
Thanks: 29
Thanked 86 Times in 73 Posts
did you do a voltage test on that stator?

my stator crapped out and there were 2 coils literally black and burnt; your's just looked darkened.

Elka 3 way shock|Penske fork valves|Leo full titanium & CF|Hyperpro steering damper|GB frame slider & engine casings|Cyclecat clipons|Pazzos|ZG|Proton|CF tank sliders|Dave Moss Techspecs|Evo Tech Sharkfin|Sato Shift Spindle holder
Glocken is offline  
post #45 of 46 Old 03-20-17, 03:46
jb.junior
Member
 
jb.junior's Avatar
 
Join Date: May 2012
Location: Houston
Posts: 363
Thanks: 2
Thanked 10 Times in 8 Posts
Quote:
Originally Posted by Glocken View Post
did you do a voltage test on that stator?

my stator crapped out and there were 2 coils literally black and burnt; your's just looked darkened.
Yes:

Resistance test: (1-2; 1-2; 2-3), all ~0.4 reading. Good test. Pins to ground: (1-ground; 2-ground; 3-ground). All "1," so that means they are open circuit -- good test.

I have the stator out right now, so I can't do an AC output voltage test. I guess I can try that tomorrow.

Yes, the coils don't look bad on this stator.
jb.junior is offline  
post #46 of 46 Old 10-18-19, 17:07
pretzel
Member
 
Join Date: Nov 2007
Location: Texas
Posts: 657
Thanks: 2
Thanked 13 Times in 13 Posts
Quote:
Originally Posted by black88iroc View Post
Here's the pic, I did notice the color of the connectors match the OEM.
I know this is an old thread, but I thought I'd add a data point for reference...FWIW, I just received my stator for my '08 from a dealer/OEM vendor in the UK and it looks just like this one (Post #13 in this thread). I know a sticker is easy to fake, but the package had the Triumph Genuine Parts label.
pretzel is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome