Triumph675.Net Forums - Search Results
Advanced Search
Showing results 1 to 6 of 6
Search took 0.00 seconds.
Search: Posts Made By: JSiN02
Forum: Maintenance and repair   03-19-19, 23:42
Replies: 5
Views: 333
Posted By JSiN02
the intake flapper huh? where is that located?...

the intake flapper huh? where is that located? and what parts exactly are down in the stator area? i’m pretty familiar w this bike (i’ve dropped the entire engine and rebuilt the head/replaced 3 bent...
Forum: Maintenance and repair   03-17-19, 16:25
Replies: 5
Views: 333
Posted By JSiN02
my revving problem.... I need some help!

what's up all....
ill try and make this as short and to the point as possible, and hope someone out there might have some advice...
my bike is a 2008 675, and most recently I did a stator swap on...
Forum: Maintenance and repair   03-17-19, 16:05
Replies: 17
Views: 1,103
Posted By JSiN02
did you figure out what might be causing your...

did you figure out what might be causing your issue?
I am having something similar going on...will be starting a new thread on it...
Forum: Repair/Troubleshooting   09-27-18, 21:48
Replies: 6
Views: 837
Posted By JSiN02
yeah I’m thinking you may be right... there def...

yeah I’m thinking you may be right... there def is a mass of the wire harness right where the back left corner of the tank comes down, and i’m thinking that it may be a broken wire in that area......
Forum: Repair/Troubleshooting   09-26-18, 21:49
Replies: 6
Views: 837
Posted By JSiN02
so i’m out at the bike again, and literally ready...

so i’m out at the bike again, and literally ready to pull my effing hair out. so i’m still not getting spark, and i am focusing on the cps... when i do a resistance check on it, i’m getting .213 k...
Forum: Repair/Troubleshooting   09-26-18, 18:43
Replies: 6
Views: 837
Posted By JSiN02
cranks but no spark... need some advice.

hey all... this is my first post on the forum...
my bikes a 2008 daytona 675, and i live in oakland/bay area...

i love this bike a lot, but recently i’ve been having issue after issue , mostly...
Showing results 1 to 6 of 6

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome