Triumph675.Net Forums - Reply to Topic
Maintenance and repair Problems, fixes, general maintenance talk

Thread: Uneven Brake Pad Wear 14D675R Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-19-19 13:44
ramnakhle Not only that, but In my country this is the best time of year for riding. [emoji41]
Cool / cold and sunny weather. Lovin every second!

Cheers from Beirut




Sent from my iPhone using Tapatalk
12-19-19 13:36
keeena Glad you got it fixed! Sometimes they just need a bit more TLC; sounds like the second round of thorough cleaning did it. Pays to be very thorough when it comes to brakes. Jealous that you're riding; snow & ice on the ground here. :(
12-18-19 04:16
ramnakhle Happy to report that the problem has been solved. [emoji16]

Went on the same test ride, first with no front brake use whatsoever. Both rotors ice cold.
On way back used normally and both rotors heat up as usual.

Brake feel is amazing and a major improvement.

Brake pad replacement due next week.

Thanks for the input and I hope this helps someone with the same problem.

Cheers!


Sent from my iPhone using Tapatalk
12-17-19 14:40
MGFChapin
Quote:
Originally Posted by ramnakhle View Post
Yes after I reinstalled everything all 4 pistons move out equally when I pull the lever. Nothing snags and itís perfect.
But... Iím still feeling that drag on the wheel when I spin it manually.
Guess Iíll be sure tomorrow when I test it on the road.
Drag is normal. The Nissins drag way more than the Brembos, but I still don't get much more than a couple rotations when I spin the front wheel.
12-17-19 14:34
ramnakhle
Uneven Brake Pad Wear 14D675R

Quote:
Originally Posted by keeena View Post
Ah, good that you already tried working the pistons. I assume that means all pistons pump out reasonably evenly, yes? I'm not sure if spinning the wheel is a positive indicator. You will get some drag and might be tricky to see visually. I've never done this, but I suppose that once brakes are installed/bled that you could try feeler gage between pad and disc to see if that one side is not retracting as much as the rest? It would have to be a super-thin feeler.



Over-analyzing a bit: i see a couple of blems on the OD of a couple pistons in that pic, but hard to tell if nicks or just lighting/dust/etc... The piston OD should be flawless. If you can feel any defects with a fingernail: replace.



I'm not sure about the bleeder for the ABS bikes; never had to deal with one of those systems before & not looking forward to it. :)


Nothing on the outside of the pistons. The inside has some minor scratches but the surface in contact with the seals and caliper bores is absolutely perfect to the touch.

Yes after I reinstalled everything all 4 pistons move out equally when I pull the lever. Nothing snags and itís perfect.
But... Iím still feeling that drag on the wheel when I spin it manually.
Guess Iíll be sure tomorrow when I test it on the road.

ABS was bled itís no big deal. I used the nipple on the master cylinder and a few bubbles came out. Nothing much. No more bubbles the second time around.

Will ride to work tomorrow and update.

Thanks again!


Sent from my iPhone using Tapatalk
12-17-19 14:21
keeena Ah, good that you already tried working the pistons. I assume that means all pistons pump out reasonably evenly, yes? I'm not sure if spinning the wheel is a positive indicator. You will get some drag and might be tricky to see visually. I've never done this, but I suppose that once brakes are installed/bled that you could try feeler gage between pad and disc to see if that one side is not retracting as much as the rest? It would have to be a super-thin feeler.

Over-analyzing a bit: i see a couple of blems on the OD of a couple pistons in that pic, but hard to tell if nicks or just lighting/dust/etc... The piston OD should be flawless. If you can feel any defects with a fingernail: replace.

I'm not sure about the bleeder for the ABS bikes; never had to deal with one of those systems before & not looking forward to it. :)
12-17-19 11:05
ramnakhle P.S.

Which bleed nipple do you use when bleeding abs via Dealertool ?
It doesnít specify which one in the service manual.


Sent from my iPhone using Tapatalk
12-17-19 11:04
ramnakhle
Quote:
Originally Posted by keeena View Post
Before you rebuild, try to clean & "work" the pistons. I'm betting that you just have pistons that aren't moving as freely behind that 1 pad.

What you essentially want to do is pump the pistons out a bit with the M/C and clean them REALLY good (I'd recommend brake fluid, NOT brake cleaner). Once they are all clean, push all the pistons in, then pump them out a bit with the M/C. Repeat the "push pistons in, pump out".


Stuff needed
  • A couple small blocks of wood that will fit in the caliper; ideally a few pieces...one that will span both pistons on 1 side as well as a smaller one which will only cover 1 piston.
  • Small c-clamp or f-clamp. This is what I use. LINK.
  • Cleaning rags cut into 1" wide x 8" long strips, brake fluid

Steps for cleaning and freeing the pistons
  • Remove ONE caliper from the fork and remove the pads
  • Pump the M/C to push all 4 pistons out a little bit; just enough to expose clean piston (~1/8" or about 6mm). You may notice that some pistons do not move. Block the pistons that are moving to force the sticky ones to move out.
  • Use the cleaning rag strips to clean all around the piston. The strips are so you can thread the rag around the piston and "floss" with it. It can be a little tricky but you'll get the idea. You need to get all the dirt off the piston. If you don't regularly clean them, it can take a while. Don't use abrasives; just brake fluid.
  • Once all 4 pistons are clean, push all of them into the caliper. Pay close attention to the M/C reservoir...depending on how full it was you may overflow the res. So remove excess if needed.
  • Now pump the M/C to push all 4 pistons out. Chances are some will be slower and/or stuck. Block the free pistons to force the problem pistons to move. Use the blocks and clamp as needed to hold the pads which are moving freely. You can rig a stack of blocks to keep opposing pistons from coming out.
  • REPEAT the "pump out, push in" a number of times. You'll start to find that the pistons start moving about the same.
  • Reinstall pads, install caliper, pump M/C to tighten up the pads, then repeat whole process on the other caliper.

This process can take a while, especially if you've never done it before or never cleaned your pistons (road & brake dust can be a pain to get off). But its well worth it. I do this every year on my track bikes; it does make a difference.


Thanks for the info.
Already did that yesterday and ended up popping out one of the pistons with an over-eager lever squeeze!

Anyway I had no choice but to take out the whole caliper and took it apart completely.

Cleaned it very thoroughly and reinstalled.
It took some doing!

Anyway I refilled the system and Iím about to do an ABS bleed right now actually using Dealertool.

From what I could tell by spinning the wheel it doesnít look like my problem has been solved. Keep in mind I had to reuse the old seals since I havenít had time to source new ones.

On visual inspection they seem ok but Iím sure theyíre all dried up so will be doing all this again soon to replace them.
The pistons are practically brand new so I wonít be replacing those just yet.
Here are the pics I took.




Sent from my iPhone using Tapatalk
12-17-19 10:54
keeena Before you rebuild, try to clean & "work" the pistons. I'm betting that you just have pistons that aren't moving as freely behind that 1 pad.

What you essentially want to do is pump the pistons out a bit with the M/C and clean them REALLY good (I'd recommend brake fluid, NOT brake cleaner). Once they are all clean, push all the pistons in, then pump them out a bit with the M/C. Repeat the "push pistons in, pump out".


Stuff needed
  • A couple small blocks of wood that will fit in the caliper; ideally a few pieces...one that will span both pistons on 1 side as well as a smaller one which will only cover 1 piston.
  • Small c-clamp or f-clamp. This is what I use. LINK.
  • Cleaning rags cut into 1" wide x 8" long strips, brake fluid

Steps for cleaning and freeing the pistons
  • Remove ONE caliper from the fork and remove the pads
  • Pump the M/C to push all 4 pistons out a little bit; just enough to expose clean piston (~1/8" or about 6mm). You may notice that some pistons do not move. Block the pistons that are moving to force the sticky ones to move out.
  • Use the cleaning rag strips to clean all around the piston. The strips are so you can thread the rag around the piston and "floss" with it. It can be a little tricky but you'll get the idea. You need to get all the dirt off the piston. If you don't regularly clean them, it can take a while. Don't use abrasives; just brake fluid.
  • Once all 4 pistons are clean, push all of them into the caliper. Pay close attention to the M/C reservoir...depending on how full it was you may overflow the res. So remove excess if needed.
  • Now pump the M/C to push all 4 pistons out. Chances are some will be slower and/or stuck. Block the free pistons to force the problem pistons to move. Use the blocks and clamp as needed to hold the pads which are moving freely. You can rig a stack of blocks to keep opposing pistons from coming out.
  • REPEAT the "pump out, push in" a number of times. You'll start to find that the pistons start moving about the same.
  • Reinstall pads, install caliper, pump M/C to tighten up the pads, then repeat whole process on the other caliper.

This process can take a while, especially if you've never done it before or never cleaned your pistons (road & brake dust can be a pain to get off). But its well worth it. I do this every year on my track bikes; it does make a difference.

Use care to not pump pistons out too far. If you do, you'll find that they can be hard to push in...its because you moved the piston past the first seal (oil seal) and this can cause the piston to cock a bit. Just use care to push it back in evenly.
12-17-19 06:03
Chirp
Quote:
Originally Posted by MGFChapin View Post
You're due for a rebuild.
Yup. Sounds like it's the left that's the problem now.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome