Triumph675.Net Forums - Reply to Topic
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

Thread: Daytona hesitates at low rpm Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-18-19 17:58
MadMel
Quote:
Originally Posted by Plasmablaster View Post
Thanks for letting us know. I remember another guy with a faulty CPS but his stuttering was happening at somewhat higher RPM.
Over the years, I've had one that was no good at low RPM, and two or three that were cutting out at high RPM. I also am curious where @E30KK sourced his.
09-18-19 13:18
Plasmablaster Thanks for letting us know. I remember another guy with a faulty CPS but his stuttering was happening at somewhat higher RPM.
09-18-19 12:46
Razvan Barcan So heres the update on my bike. It seems that the cps was causing all the problems. I swapped the cps that came with the ricks stator with the oem cps and no more hesitation at low rpms. Thank you all for all the help and support. U guys are awesome.
06-10-19 13:57
Razvan Barcan
Quote:
Originally Posted by MadMel View Post
Quote:
Originally Posted by E30KK View Post
Hi guys,


i had exact the same problem with my 2011 Daytona after i replaced a broken CPS. I bought a new aftermarket CPS from a guy in a german forum. Then i tried those china CPS (MadMels link) and it also failed. The stuttering was even worse with that one. Then i bought an OEM CPS from a Triumph dealer here in germany. Normalwise you dont get it separately, but this guy sells them for around 85€. This solved the problem for me. My bike runs perfect again. So i really donīt recommend aftermarket CPS as they simply donīt work properly. It took me weeks to find out, checking almost everything else and changing maps etc.


Greets from Germany
Paul
Quote:
Originally Posted by Philduck161 View Post
Thats super helpful might get one as a spare. Who's the dealer?

Sent from my SM-G950F using Tapatalk
I'm thinking that @E30KK may have found a supplier for PVL CPSes, which are made in Germany and are stock on some Triumphs.

I would be interested in buying one as well in case my current one fails again. Could you let us know where u bought it from in Germany? Thanks.
06-10-19 04:16
MadMel
Quote:
Originally Posted by E30KK View Post
Hi guys,


i had exact the same problem with my 2011 Daytona after i replaced a broken CPS. I bought a new aftermarket CPS from a guy in a german forum. Then i tried those china CPS (MadMels link) and it also failed. The stuttering was even worse with that one. Then i bought an OEM CPS from a Triumph dealer here in germany. Normalwise you dont get it separately, but this guy sells them for around 85€. This solved the problem for me. My bike runs perfect again. So i really donīt recommend aftermarket CPS as they simply donīt work properly. It took me weeks to find out, checking almost everything else and changing maps etc.


Greets from Germany
Paul
Quote:
Originally Posted by Philduck161 View Post
Thats super helpful might get one as a spare. Who's the dealer?

Sent from my SM-G950F using Tapatalk
I'm thinking that @E30KK may have found a supplier for PVL CPSes, which are made in Germany and are stock on some Triumphs.
05-30-19 05:28
E30KK If they work for you, great! For me they didnīt. Tried two of them!
05-29-19 17:55
MadMel
Quote:
Originally Posted by E30KK View Post
Hi guys,


i had exact the same problem with my 2011 Daytona after i replaced a broken CPS. I bought a new aftermarket CPS from a guy in a german forum. Then i tried those china CPS (MadMels link) and it also failed. The stuttering was even worse with that one. Then i bought an OEM CPS from a Triumph dealer here in germany. Normalwise you dont get it separately, but this guy sells them for around 85€. This solved the problem for me. My bike runs perfect again. So i really donīt recommend aftermarket CPS as they simply donīt work properly. It took me weeks to find out, checking almost everything else and changing maps etc.


Greets from Germany
Paul
The reason that nearly everyone who owns a Daytona looks at aftermarket CPSes is because their factory CPS has failed. Just like most aftermarket ones, the factory CPSes are junk, they're just much more expensive junk.
05-29-19 16:08
Philduck161
Quote:
Originally Posted by E30KK View Post
Hi guys,


i had exact the same problem with my 2011 Daytona after i replaced a broken CPS. I bought a new aftermarket CPS from a guy in a german forum. Then i tried those china CPS (MadMels link) and it also failed. The stuttering was even worse with that one. Then i bought an OEM CPS from a Triumph dealer here in germany. Normalwise you dont get it separately, but this guy sells them for around 85€. This solved the problem for me. My bike runs perfect again. So i really donīt recommend aftermarket CPS as they simply donīt work properly. It took me weeks to find out, checking almost everything else and changing maps etc.


Greets from Germany
Paul
Thats super helpful might get one as a spare. Who's the dealer?

Sent from my SM-G950F using Tapatalk
05-26-19 05:55
E30KK Hi guys,


i had exact the same problem with my 2011 Daytona after i replaced a broken CPS. I bought a new aftermarket CPS from a guy in a german forum. Then i tried those china CPS (MadMels link) and it also failed. The stuttering was even worse with that one. Then i bought an OEM CPS from a Triumph dealer here in germany. Normalwise you dont get it separately, but this guy sells them for around 85€. This solved the problem for me. My bike runs perfect again. So i really donīt recommend aftermarket CPS as they simply donīt work properly. It took me weeks to find out, checking almost everything else and changing maps etc.


Greets from Germany
Paul
05-13-19 01:32
Razvan Barcan
Quote:
Originally Posted by MadMel View Post
https://www.ebay.com/itm/222603501414

I misspelled his name, that wouldn't have helped your search. Forum user Far Canal has posted this link a couple of times. I searched eBay using terms from that 🔗 and found many sellers.
Thanks for the link. I went ahead and bought it.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome