Triumph675.Net Forums - Reply to Topic
Thread: ABS & Engine light and Fuel Economy Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-21-18 08:51
Bttbtt1024 Have you found out what the issue was?
02-06-18 15:53
Magnum Maximum
ABS & Engine light and Fuel Economy

Both my ABS and engine light came on yesterday. However, ABS would turn off after a while. Engine light is still on. I also noticed fuel economy dropping significantly. Was at 40 mpg - now I'm under 30 and dropping. Will check the code(s) from the OBD II when I get home today. Either I'm leaking fuel or my brakes are constantly being applied when I'm not using them and that's causing me to use enough extra engine power to not be immediately noticeable but to effect fuel economy. Any other ideas are welcomed. If it's an issue with the brakes, can I fix it myself?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome