First 200 miles on my '12 STR. - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > The Street Triple 675!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-03-12, 22:07   #1
Zen
Member
 
Zen's Avatar
 
Join Date: Oct 2012
Location: Anaheim
Posts: 210
Thanks: 0
Thanked 1 Time in 1 Post
Default First 200 miles on my '12 STR.

Things I NEED: New levers, grips, and rear sets, stocks are horrible. Blinkers. Flyscreen. Better upright helmet.

Things I WANT: Aftermarket header/down pipe, mid pipe, and slip on cans or arrow 3-1. Fender eliminator. Xenon/Hids.

Other than that, this bike is amazing, I'm in love for the first time. Each day I feel more and more comfortable on it, each day the bond/stability/trust between me and the bike improves.
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 11-04-12, 01:00   #2
Duc Hunter 675
Senior Member
 
Duc Hunter 675's Avatar
 
Join Date: Sep 2011
Location: Clifton, New Jersey
Posts: 917
Thanks: 1
Thanked 5 Times in 4 Posts
Default

I agree on a few of these. Shorty levers watson blinkers and fender eliminator are a must.. how tall are you. Im surprised you dont like the stock rearsets. They are good but maybe you are to tall. Have fun making her yours. Only you know what you really like. Watsons are a must though. Best blinkers ever.

Sent from my DROID RAZR using Motorcycle.com App
__________________
2011 Daytona
2009 Er-6n
Status: Offline
 
Reply With Quote
Old 11-04-12, 11:20   #3
Zen
Member
 
Zen's Avatar
 
Join Date: Oct 2012
Location: Anaheim
Posts: 210
Thanks: 0
Thanked 1 Time in 1 Post
Default

I'll check out the watsons! Better than rizomas? I'm 6'2"...
Status: Offline
 
Reply With Quote
Old 11-04-12, 13:03   #4
fourthreesix
Junior Member
 
fourthreesix's Avatar
 
Join Date: Jun 2010
Location: Pittsburg, CA
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The Watsons don't fit the best in the Street Triple radiator cowls compared to the Daytona. Triumph has some nice billet aluminum LED signals I plan on putting on my scooter.



I'm the same height and don't mind the stock rearsets too much. Only reason I plan on replacing them is for looks, more than anything.
__________________
Gordon

08 Street Triple
Status: Offline
 
Reply With Quote
Old 11-04-12, 13:26   #5
Duc Hunter 675
Senior Member
 
Duc Hunter 675's Avatar
 
Join Date: Sep 2011
Location: Clifton, New Jersey
Posts: 917
Thanks: 1
Thanked 5 Times in 4 Posts
Default

I see what you mean about the watsons. I never realized the didnt fit the street. Those look like some nice blinkers from triumph though. Anything rizoma is usually pretty hot also.

Sent from my DROID RAZR using Motorcycle.com App
__________________
2011 Daytona
2009 Er-6n
Status: Offline
 
Reply With Quote
Old 11-04-12, 16:11   #6
Zen
Member
 
Zen's Avatar
 
Join Date: Oct 2012
Location: Anaheim
Posts: 210
Thanks: 0
Thanked 1 Time in 1 Post
Default

I really like the feel of the arrow rearsets.
Status: Offline
 
Reply With Quote
Old 11-07-12, 10:03   #7
Zen
Member
 
Zen's Avatar
 
Join Date: Oct 2012
Location: Anaheim
Posts: 210
Thanks: 0
Thanked 1 Time in 1 Post
Default

So far I've filled the tank 3 times and have just over 200 miles on the odometer...

First 30 miles I took her out on the highway and covered all rpms in 2nd,3rd, and 4th, used a lot of engine braking, and sealed those rings nice and snug. The engine sounds and runs great. I drive city to work, a lot of stop and go. Still no flyscreen, combine that with the amount of engine braking/downshifting I do, the brakes have barely been used, so what could be the reason for my crappy gas mileage so far? These things I've explained or something else? engine temp runs at 6 bars.


Sent from my iPhone using Motorcycle.com Free App
Status: Offline
 
Reply With Quote
Old 11-07-12, 11:20   #8
chinoamigo
Junior Member
 
chinoamigo's Avatar
 
Join Date: May 2012
Location: Los Angeles
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

your MPG seems REALLY low. how much gallons are you putting in each time? are you filling it up (manually) all the way? if the light comes on you should be able to put about 3.7 gal or so in
Status: Offline
 
Reply With Quote
Old 11-07-12, 11:29   #9
vintagespeed
Member
 
Join Date: Aug 2012
Location: Rancho Cucamonger
Posts: 684
Thanks: 5
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by Zen View Post
So far I've filled the tank 3 times and have just over 200 miles on the odometer.......
make sure your fan is working properly, something is very off.

i have a '12 as well and am in Rancho Cucamonga, i commute daily and get 160-170/tank, my gauge has never gone over 5 bars.

make sure your computer is set to US gallons.

Last edited by vintagespeed; 11-07-12 at 11:30. Reason: i apparently love the term "as well"
Status: Offline
 
Reply With Quote
Old 11-07-12, 15:57   #10
Zen
Member
 
Zen's Avatar
 
Join Date: Oct 2012
Location: Anaheim
Posts: 210
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by chinoamigo View Post
your MPG seems REALLY low. how much gallons are you putting in each time? are you filling it up (manually) all the way? if the light comes on you should be able to put about 3.7 gal or so in
Quote:
Originally Posted by vintagespeed View Post
make sure your fan is working properly, something is very off.

i have a '12 as well and am in Rancho Cucamonga, i commute daily and get 160-170/tank, my gauge has never gone over 5 bars.

make sure your computer is set to US gallons.
Guys, when I first got the bike(shipped to my house) I fired it up before my first ride and realized that the gas light was on, I called the dealer and he told me that he did not fill it with gas. I shut the engine off, I filled it with 1 gallon of 91 octane via a gas can, then drove it straight to the gas station to fill the rest of the tank. Could I have ruined something with the fuel system there?

My first day on the bike the gas light came on after about 60-70 miles.

Every time I fill, the first click happens between 2.7-2.9 gallons, which is low. I never over filled, one click and that's it. The temp gauge is usually at 6, and will drop to 5 with some good head wind, but then go back to 6 during deceleration and/or acceleration.

Everything else is working great on the bike, no foreign sounds or smells, just this gas mileage issue.
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum