Help identifying CEL and creative wiring issue - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > Modifications > All Things Tuning

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-17-12, 10:59   #1
Shnrdrgz79
Junior Member
 
Join Date: Feb 2012
Location: Kansas City
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help identifying CEL and creative wiring issue

I bought a used '07 D675 with a 2 Bros slip on exhaust and the CEL (check engine light) on, the price was really good don't judge me ;). The bike has never had any issues other than the battery losing its charge relatively quickly on cold days/nights. I was told the CEL was on due to the removal of the o2 sensor and exhaust valve when the exhaust was put on by the original owner. Upon further inspection of my bike (wiring harness under the seat) it looks like there is a "bypass" wire in the female end of the wiring harness plug (which is disconnected), I assume it's there so the bike will run without the o2 sensor and exup valve, but I am not sure. Any ideas anyone? I can post a picture later for clarification. I ask because I want to get rid of the "creative wiring" and CEL, especially before I invest in a new battery.

I have been looking into using TuneEcu to resolve the issue but I have no experience with it and I am not the most computer savvy guy. Is there a recommended OBD2 cable? I have seen a couple on eBay and Amazon that are the 1.5 version.

Any help would be appreciated. Thanks
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 10-20-12, 15:52   #2
wfire19
Junior Member
 
wfire19's Avatar
 
Join Date: Oct 2011
Location: Green Bay
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Default

if you want to first you can take the bike to an O'Rielys or Autozone and have them use their equipment for doing the check engine lights on cars, write down there error code that comes up, i cant remember off the top of my head how i found it, just know i searched it but there is a whole thread with what all the error codes mean
Status: Offline
 
Reply With Quote
Old 10-20-12, 15:57   #3
kyle319
Member
 
Join Date: Sep 2010
Location: Cedar Falls, Iowa
Posts: 224
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[ame="http://www.triumph675.net/forum/showthread.php?t=52437"]675 Torque Specs and General Specs - Triumph675.Net Forums[/ame]

just scroll down past the torque specs to find the codes
Status: Offline
 
Reply With Quote
Old 10-31-12, 17:00   #4
Baba Zanetti
Member
 
Baba Zanetti's Avatar
 
Join Date: Oct 2007
Location: Sydney
Posts: 430
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The bypass wire is normal, it's the factory alarm connector if you remove the wire the bike won't start.

Check that the exup has really been removed or wired open, get an appropriate map for the slip on from here and load it and clear the CEL light, simple.
Also check the charging system as per the diagnostics thread, your bike may be in the recall range for the reg so even if the charging system is fine now get the recall done.
__________________
07 Graphite: Full Leo Vince system--K&N air filter--Self machined copy of Flux's Link plates--APE manual camchain tensioner--Elka 3-way rear shock--Shock Treatment [AU] tweaked Forks--zero bling bits
Status: Offline
 
Reply With Quote
Old 11-05-12, 20:22   #5
Shnrdrgz79
Junior Member
 
Join Date: Feb 2012
Location: Kansas City
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks guys!

Thanks for the input guys! I haven't had time to try work on the bike but I think I will take it up to O'reilly's and get the error code investigated and verify if the exup valve is removed.
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
cel, check engine light, tuneecu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum