Help identifying CEL and creative wiring issue - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 5 Old 10-17-12, 10:59 Thread Starter
Shnrdrgz79
Junior Member
 
Join Date: Feb 2012
Location: Kansas City
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Help identifying CEL and creative wiring issue

I bought a used '07 D675 with a 2 Bros slip on exhaust and the CEL (check engine light) on, the price was really good don't judge me ;). The bike has never had any issues other than the battery losing its charge relatively quickly on cold days/nights. I was told the CEL was on due to the removal of the o2 sensor and exhaust valve when the exhaust was put on by the original owner. Upon further inspection of my bike (wiring harness under the seat) it looks like there is a "bypass" wire in the female end of the wiring harness plug (which is disconnected), I assume it's there so the bike will run without the o2 sensor and exup valve, but I am not sure. Any ideas anyone? I can post a picture later for clarification. I ask because I want to get rid of the "creative wiring" and CEL, especially before I invest in a new battery.

I have been looking into using TuneEcu to resolve the issue but I have no experience with it and I am not the most computer savvy guy. Is there a recommended OBD2 cable? I have seen a couple on eBay and Amazon that are the 1.5 version.

Any help would be appreciated. Thanks
Shnrdrgz79 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-20-12, 15:52
wfire19
Junior Member
 
wfire19's Avatar
 
Join Date: Oct 2011
Location: Green Bay
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
if you want to first you can take the bike to an O'Rielys or Autozone and have them use their equipment for doing the check engine lights on cars, write down there error code that comes up, i cant remember off the top of my head how i found it, just know i searched it but there is a whole thread with what all the error codes mean
wfire19 is offline  
post #3 of 5 Old 10-20-12, 15:57
kyle319
Member
 
Join Date: Sep 2010
Location: Cedar Falls, Iowa
Posts: 224
Thanks: 0
Thanked 0 Times in 0 Posts
[ame="http://www.triumph675.net/forum/showthread.php?t=52437"]675 Torque Specs and General Specs - Triumph675.Net Forums[/ame]

just scroll down past the torque specs to find the codes
kyle319 is offline  
post #4 of 5 Old 10-31-12, 17:00
Baba Zanetti
Member
 
Baba Zanetti's Avatar
 
Join Date: Oct 2007
Location: Sydney
Posts: 430
Thanks: 0
Thanked 0 Times in 0 Posts
The bypass wire is normal, it's the factory alarm connector if you remove the wire the bike won't start.

Check that the exup has really been removed or wired open, get an appropriate map for the slip on from here and load it and clear the CEL light, simple.
Also check the charging system as per the diagnostics thread, your bike may be in the recall range for the reg so even if the charging system is fine now get the recall done.

07 Graphite: Full Leo Vince system--K&N air filter--Self machined copy of Flux's Link plates--APE manual camchain tensioner--Elka 3-way rear shock--Shock Treatment [AU] tweaked Forks--zero bling bits
Baba Zanetti is offline  
post #5 of 5 Old 11-05-12, 20:22 Thread Starter
Shnrdrgz79
Junior Member
Threadstarter Threadstarter
 
Join Date: Feb 2012
Location: Kansas City
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks guys!

Thanks for the input guys! I haven't had time to try work on the bike but I think I will take it up to O'reilly's and get the error code investigated and verify if the exup valve is removed.
Shnrdrgz79 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
cel , check engine light , tuneecu

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome