Rough idle and various electric problems FIX! - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > Maintenance and repair > Repair/Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-02-12, 00:01   #1
Samman445
Junior Member
 
Samman445's Avatar
 
Join Date: Jul 2011
Location: Columbia MO.
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default Rough idle and various electric problems FIX!

So this has happened to me twice in 10 thousand miles and it made me angry both times so i just thought I would share. The basic problem is a rough idle with the bike even threatening to die every now and then. This latest time it was accompanied by a flickering back light on the instrument cluster and a blinker that would occasionally blink fast as if one of the bulbs was out but upon inspection both front and rear are working. These problems weren't really an issue once the bike gets going. Naturally I was worried and feared an r/r or another electrical issue. This may be an obvious fix to an experienced mechanic but all I had to do was tighten both battery cables! I felt like such an idiot when I turned the screwdriver a fraction of an inch and that was all I had to do. So if you have a similar problem please please please don't immediately go out and buy a new stator or r/r or even take it to a dealer. Just tighten the battery cables! If anyone has any other advice or wants to call me stupid for not knowing this feel free, but I thought I could save some time for some people who overlooked this simple fix like I did.
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 03-02-12, 01:14   #2
Daytona Dreadie
Member
 
Daytona Dreadie's Avatar
 
Join Date: Feb 2012
Location: Kansas City, Kansas
Posts: 166
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Glad it wasn't the R/R! Good advice! Many may not think twice and take it to their Triumph dealer.. always good to troubleshoot! I'm in the KC area, enjoy having your Daytona while everyone else puts +10 tooth rear sprockets on their 636 and f4i's and wheelies them down the highway! Absolutely bonkers..

Ride on
__________________
'06 Triumph Daytona 675
'05 Honda CR125R (dirt)

"Just because you're breathing, doesn't mean you're alive."

Spiral out..
Status: Offline
 
Reply With Quote
Old 09-05-12, 17:58   #3
Swerve test survivor
Junior Member
 
Join Date: Sep 2012
Location: Wigan
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just had this exact problem happen to me on a ride out. I also had problems getting it started (power would cut out when I pressed the starter and fuel pump priming started up again.)

a google search turned up this thread and a quick examination under the seat turned up a loose terminal screw.

I too was immediately thinking of thing much worse!

Thanks for posting!
Status: Offline
 
Reply With Quote
Old 11-29-12, 22:52   #4
spargett
Member
 
spargett's Avatar
 
Join Date: Jul 2010
Location: Los Angeles, CA
Posts: 305
Thanks: 0
Thanked 1 Time in 1 Post
Default

I have the same problems, but just checked the terminals. Both rock solid. Just wanted to share that it isn't always the case. In regards to the instrument panel flickering, mine was more of a subtle pulsing than any sort of on/off action.

I'm suspecting the Idle Stepper Motor either needing calibration or replacement.
Status: Offline
 
Reply With Quote
Old 02-06-13, 09:06   #5
EvanMO
Junior Member
 
Join Date: Nov 2012
Location: Estero, FL
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a similar problem....already had the R/R replaced about two months ago. When i start the bike it will start on the second try, then when I am out cruising it is fine. Then when I stop at a red light or stop sign in 1st gear, he bike idles very rough and below 1k RPM's until it eventually shuts off. The instrument panel flickers and the gas light flickers. Similiar to what happened with you? Thinking about just taking it in anyway. please let me know
Status: Offline
 
Reply With Quote
Old 02-06-13, 12:33   #6
spargett
Member
 
spargett's Avatar
 
Join Date: Jul 2010
Location: Los Angeles, CA
Posts: 305
Thanks: 0
Thanked 1 Time in 1 Post
Default

Sounds electrical to me. I'd check your battery connections, and battery level. My problem was a failed alarm unit that was sucking voltage intermittently. As soon as I removed it, problem solved. Could be your R/R though, did they replace it with the upgraded version per the soft recall?

Quote:
Originally Posted by EvanMO View Post
I have a similar problem....already had the R/R replaced about two months ago. When i start the bike it will start on the second try, then when I am out cruising it is fine. Then when I stop at a red light or stop sign in 1st gear, he bike idles very rough and below 1k RPM's until it eventually shuts off. The instrument panel flickers and the gas light flickers. Similiar to what happened with you? Thinking about just taking it in anyway. please let me know
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum