what did you do to your 675 today???? - Page 885 - Triumph675.Net Forums
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

Reply
 
Thread Tools Display Modes
post #8841 of 8847 Old 02-22-17, 14:02
Phicurious86
Member
 
Phicurious86's Avatar
 
Join Date: Mar 2016
Location: Phoenix, AZ
Posts: 201
Thanks: 9
Thanked 23 Times in 22 Posts
Garage
Quote:
Originally Posted by jubei4769 View Post
Yea I've been meaning to pick up a set. Just one of those things I guess, slow speed, gravel, front wheel slid out and I lost my footing cause the gravel so it fell over. Was more embarrassed than anything


Sent from my iPhone using Tapatalk
Dropped mine by forgetting to put the kickstand back down after doing a bunch of maintenance on the bike.

Lowered her off the rear stand like I normally do and down she went.

Real punch in the gut, but it happens to everyone for all kinds of reasons.
Phicurious86 is offline  
Sponsored Links
Advertisement
 
post #8842 of 8847 Old 02-22-17, 17:26
gall
Junior Member
 
Join Date: Feb 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Added tech spec snake skin tank pads, oem engine cover kit, and buying necessary tools to get the fairings off to put on my oem frame sliders!
gall is online now  
post #8843 of 8847 Old 02-25-17, 19:17
littlehat
Junior Member
 
littlehat's Avatar
 
Join Date: Mar 2014
Location: san diego
Posts: 66
Thanks: 2
Thanked 1 Time in 1 Post
Blew up my motor at chuckwalla yesterday.... Didn't grenade, but blowing smoke out the tail pipe and up by the heads. Felt a loss of power and then wouldn't Rev above 8k. Got off the track immediately and it died in first gear in the hot pits. It's a 2012 bike. I guess I'll have to cracking it open to see what's wrong. If it needs a full rebuild I'm contemplating sourcing a post 13 engine and seeing how that works or parting it out to fund a lightweight build.

Sent from my SM-G900V using Tapatalk
littlehat is offline  
 
post #8844 of 8847 Old 02-25-17, 22:07
bill_yyy
Junior Member
 
Join Date: Mar 2015
Location: Sydney
Posts: 46
Thanks: 0
Thanked 3 Times in 3 Posts
Wired up most of my Bazzaz Z-Fi and replaced the coolant bypass hose.

I just need to get to the crank position sensor plug now for the Bazzaz to be 100% wired up. Plus install Driven block off plates
bill_yyy is offline  
post #8845 of 8847 Old 02-26-17, 00:38
Shamrock
Moderator
 
Shamrock's Avatar
 
Join Date: Sep 2010
Location: Kentucky
Posts: 1,566
Thanks: 260
Thanked 115 Times in 94 Posts
Rode it yesterday, with record high temps (79), also have a GPR damper waiting to go on.
Shamrock is offline  
post #8846 of 8847 Old 02-26-17, 09:34
Weaver412@yahoo.com
Junior Member
 
Join Date: Jan 2017
Location: Columbus
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
I hooked up the obd cable and did my first flash. I bought a set of headers somebody did a nice job of removing the cat and exup and installed them. After which downloaded the tuneecu app on my android tablet and installed a full exhaust map and disabled the exup valve. Now I'm just waiting on the two brothers slip on. I'm turning this bike into a track day street bike. I have a 2014 S1000rr but that's my Tail of the dragon/ twisties bike.

Sent from my VS990 using Tapatalk
Weaver412@yahoo.com is offline  
post #8847 of 8847 Old 02-26-17, 20:16
Razgriz81
Member
 
Razgriz81's Avatar
 
Join Date: Mar 2013
Location: North Salt Lake
Posts: 293
Thanks: 83
Thanked 10 Times in 10 Posts
Click image for larger version

Name:	uploadfromtaptalk1488154556137.jpg
Views:	28
Size:	191.7 KB
ID:	223018Click image for larger version

Name:	uploadfromtaptalk1488154560895.jpg
Views:	30
Size:	190.6 KB
ID:	223026 Tore my 12 apart and painted my subframe... really pops it out in my opinion.

Sent from my SM-G935P using Tapatalk

Respect the machine and the machine will respect you.....

Other toys: 81 Camaro Z28 400 SBC 4 speed manual (converted from auto), 71 Blazer 454 BBC 4 speed manual (factory), 98 Camaro Z28 5.7L LS1 auto, 06 Arctic Cat M6, 96 Arctic Cat ZRT600
Razgriz81 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome