Replacing indicator on Street Triple - how? - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 2 Old 03-28-09, 13:09 Thread Starter
Sculler
Junior Member
 
Join Date: Mar 2009
Location: Geneva
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Replacing indicator on Street Triple - how?

Hi all,

My first post, but I've been reading the forum for a little while since getting my Street Triple a couple of months ago.

Anyway, I have a little problem - I need to replace a front indicator, and having collected the new one from the shop, am having some problems working out how to do it...

The wire runs out the back of the plastic fairing which covers the side of the radiator and then just disappears into a tight hole up underneath the tank. I've hinged up the tank, but there is a big plastic lump under there (where the fuses, ECU etc are attached), where the wire must go, but I have no idea how to get underneath to unplug the bust indicator and how to feed the wire for the new one through.

Any ideas anyone?! All comments gratefully received

Cheers,
Sculler
Sculler is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-08-09, 14:55
corpsedub
Junior Member
 
corpsedub's Avatar
 
Join Date: Jan 2009
Location: san jose,ca
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Sculler View Post
Hi all,

My first post, but I've been reading the forum for a little while since getting my Street Triple a couple of months ago.

Anyway, I have a little problem - I need to replace a front indicator, and having collected the new one from the shop, am having some problems working out how to do it...

The wire runs out the back of the plastic fairing which covers the side of the radiator and then just disappears into a tight hole up underneath the tank. I've hinged up the tank, but there is a big plastic lump under there (where the fuses, ECU etc are attached), where the wire must go, but I have no idea how to get underneath to unplug the bust indicator and how to feed the wire for the new one through.

Any ideas anyone?! All comments gratefully received

Cheers,
Sculler
unscrew the alen bolt that holds the signal on the body. then using a small philips head, unsrew the small screw at the end of the clear housing and pop the light fixture from the housing. you can then remove the spade connectors from the fixture and pop a new one on.
corpsedub is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome