Bike not cranking. - Page 3 - Triumph675.Net Forums
Reply
 
Thread Tools Display Modes
post #21 of 21 Old 12-11-12, 22:37
MacBandit
Senior Member
 
MacBandit's Avatar
 
Join Date: Sep 2008
Location: Seattle
Posts: 10,104
Thanks: 2
Thanked 127 Times in 115 Posts
Garage
Correct. We also know that the starter button and ecu are working because you hear either the starter relay or solenoid clicking. Yes there are basically two relays for the starter they call one a solenoid just because it handles the actual high load of the starter circuit.
MacBandit is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome