what did you do to your 675 today???? - Page 395 - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > General 675 discussion

General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-11-12, 15:55   #3941
Tucker2.0
Member
 
Tucker2.0's Avatar
 
Join Date: Jun 2012
Location: Hickory, NC
Posts: 504
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Tucker2.0
Default

Started taking the farings off and getting to the bottom of why im getting oil in the piston chamber.

Only first after ive started it, so im fairly certain its the valve guides.
__________________
2007 SV650S -RIP suziQ
2010 Daytona 675SE -I miss my SV, but damn that daytona!
1980 Honda cm200t (running work in progress)
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 12-11-12, 16:31   #3942
twistyrider
Member
 
twistyrider's Avatar
 
Join Date: Mar 2012
Location: San Antonio
Posts: 238
Thanks: 14
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by allaussiegrown View Post
Get the dynojet shift rod connector kit.
I already ordered the one from Sato. I was gonna get the Dynojet, but its 135mm and I couldnt find how short you could cut it. Didnt want to waste the time & money if it wouldnt fit and it was only $32 shipped from sato for the D675R shift rod
Status: Offline
 
Reply With Quote
Old 12-11-12, 21:00   #3943
Ricardo_
Senior Member
 
Ricardo_'s Avatar
 
Join Date: May 2010
Location: São Paulo (Brasil)
Posts: 818
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by Cel675 View Post
Soon as my steel tube frame is done being built I will make a thread.
I want to see this so bad!
Status: Offline
 
Reply With Quote
Old 12-12-12, 04:48   #3944
MadMel
Senior Member
 
MadMel's Avatar
 
Join Date: Feb 2012
Location: Brisbane
Posts: 1,498
Thanks: 58
Thanked 28 Times in 20 Posts
Default

Yanked the wheels to get new Dunlop NTec slicks tomorrow, cleaned the calipers and pads, cleaned & lubed the chain, cleaned and re-oiled the MWR HE air filter.
Status: Offline
 
Reply With Quote
Old 12-12-12, 14:50   #3945
Dino7
Member
 
Dino7's Avatar
 
Join Date: Mar 2012
Location: Sydney
Posts: 266
Thanks: 2
Thanked 7 Times in 7 Posts
Default

Just received my parcel Riders Discount, big thanks to TJ, package contents, Comp Werkes/CF dual slip on, Comp Werkes LTD fender eliminator, Lightech chain adjusters, can't wait to fit the goodies this weekend.


Sent from my iPhone using Motorcycle.com App
Status: Offline
 
Reply With Quote
Old 12-12-12, 22:36   #3946
Daytona3
Member
 
Daytona3's Avatar
 
Join Date: Aug 2012
Location: Jacksonville FL
Posts: 247
Thanks: 25
Thanked 2 Times in 2 Posts
Default

Click image for larger version

Name:	ImageUploadedByMO Free1355369719.635612.jpg
Views:	120
Size:	149.9 KB
ID:	34380
got the triple tree finished while waiting to heal from my shoulder surgery, :-)


Sent from my iPhone using Motorcycle.com Free App
Status: Offline
 
Reply With Quote
Old 12-13-12, 20:16   #3947
twistyrider
Member
 
twistyrider's Avatar
 
Join Date: Mar 2012
Location: San Antonio
Posts: 238
Thanks: 14
Thanked 5 Times in 4 Posts
Default

Rearsets are on!

Status: Offline
 
Reply With Quote
Old 12-13-12, 22:27   #3948
NastyNate
Junior Member
 
Join Date: Sep 2012
Location: SA,TX
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I adjusted my Danmoto clipons... and now I have a check engine light on out of nowhere. I did move the brake resivoir and need to rebleed it and removed the plug in where the turn signal plug goes. Other than that everything stayed the same.
Anyone have any ideas?
Status: Offline
 
Reply With Quote
Old 12-14-12, 01:19   #3949
twistyrider
Member
 
twistyrider's Avatar
 
Join Date: Mar 2012
Location: San Antonio
Posts: 238
Thanks: 14
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by NastyNate View Post
I adjusted my Danmoto clipons... and now I have a check engine light on out of nowhere. I did move the brake resivoir and need to rebleed it and removed the plug in where the turn signal plug goes. Other than that everything stayed the same.
Anyone have any ideas?
Whenever you're free, if you want you can swing by my house. I can hook it up to ecutune and see what that light is. I live off of 1604 & potranco about 2 miles outside the loop. Just PM me & I can give you my address.
Status: Offline
 
Reply With Quote
Old 12-16-12, 17:43   #3950
Cloud22116
Senior Member
 
Cloud22116's Avatar
 
Join Date: Sep 2010
Location: Oahu
Posts: 2,123
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Went for a ride with a buddy crappy weather but fun time none the less.
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1355697717986.jpg
Views:	62
Size:	33.1 KB
ID:	34446   Click image for larger version

Name:	uploadfromtaptalk1355697731506.jpg
Views:	67
Size:	35.6 KB
ID:	34447   Click image for larger version

Name:	uploadfromtaptalk1355697744321.jpg
Views:	62
Size:	29.9 KB
ID:	34448   Click image for larger version

Name:	uploadfromtaptalk1355697757233.jpg
Views:	63
Size:	34.2 KB
ID:	34449   Click image for larger version

Name:	uploadfromtaptalk1355697768392.jpg
Views:	59
Size:	26.3 KB
ID:	34450  

Click image for larger version

Name:	uploadfromtaptalk1355697781726.jpg
Views:	61
Size:	17.2 KB
ID:	34451   Click image for larger version

Name:	uploadfromtaptalk1355697796116.jpg
Views:	69
Size:	22.7 KB
ID:	34452   Click image for larger version

Name:	uploadfromtaptalk1355697819692.jpg
Views:	69
Size:	36.5 KB
ID:	34453  
__________________
2009 Daytona 675
Akra headers/comp werks exhaust, 1050 throttle tube, ohlins ttx rear shock, bazzaz zfi fuel controller/QS, MWR air filter, attack rear sets, galfer rotors front and rear, brembo MC,
2013 Aprilia RSV-4
stock for now
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright ©2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Kawasaki Ninja H2 Forum