My bike died on me - Page 2 - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > Maintenance and repair > Repair/Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-09-12, 13:06   #11
weezy84
Member
 
Join Date: Mar 2011
Location: NoVA
Posts: 227
Thanks: 4
Thanked 1 Time in 1 Post
Default

edited

Last edited by weezy84; 12-13-12 at 17:24. Reason: created new thread
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 12-09-12, 14:40   #12
nixthewiz
Junior Member
 
Join Date: Feb 2012
Location: Santa Ana
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not so sure if it's the RR that went bad. Other people with bad RRs report their batteries got drained. My bike just doesn't do that. I started up 3 times no problem after I shut it down.

I'm hesitant to take it back out cause I don't want it to die on me in traffic again. All of a sudden when I'm riding the rev just goes crazy. No power then goes up to 7-8k rpm and then no power and then goes to 7k rpm and then no power and then goes back to high rpms. After that it just lose all power to the rearwheel no matter how much throttle I give it and I have to coast to a stop then the engine shuts off when the bike is stopped. I'll check the voltage tomorrow and see if it's something electrical.

Last edited by nixthewiz; 12-09-12 at 14:47.
Status: Offline
 
Reply With Quote
Old 12-09-12, 19:18   #13
Ruby Racing
BOTM Winner
 
Ruby Racing's Avatar
 
Join Date: Jan 2009
Location: Jersey, Channel Islands
Posts: 2,220
Thanks: 0
Thanked 19 Times in 17 Posts
Default

Quote:
Originally Posted by nixthewiz View Post
I asked the previous owner and he said before he sold it to me his local dealer replaced the RR under the recall.
If you bought the bike more than a couple of months ago then it wouldn't have been done under the recall as that only came up in about August. It may well have been replaced, but with another crap one. If you look for a thread I started recently then you will see I have posted a photo of the crap R/R next to the good recall R/R. See which one you have. In any event give your dealer the bike VIN and see if it has been fixed under warranty. If not then get it done sharpish.

Not sure if the R/R is the problem in your case as the symptoms seems different to those usually reported on here, but for peace of mind I'd find out for sure if the R/R has been replaced with the MOSFET unit. Quick and easy to do if you check out my photo.
__________________

To read about the transformation click > Project Trixie Transformation

For comparison photo of old R/R with new improved R/R under recall of 2012 click > R/R Comparison Photos
Status: Offline
 
Reply With Quote
Old 12-09-12, 22:05   #14
nixthewiz
Junior Member
 
Join Date: Feb 2012
Location: Santa Ana
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ruby Racing View Post
If you bought the bike more than a couple of months ago then it wouldn't have been done under the recall as that only came up in about August. It may well have been replaced, but with another crap one. If you look for a thread I started recently then you will see I have posted a photo of the crap R/R next to the good recall R/R. See which one you have. In any event give your dealer the bike VIN and see if it has been fixed under warranty. If not then get it done sharpish.

Not sure if the R/R is the problem in your case as the symptoms seems different to those usually reported on here, but for peace of mind I'd find out for sure if the R/R has been replaced with the MOSFET unit. Quick and easy to do if you check out my photo.
I just got the bike recently in october. Called my local dealer they said no oustanding recall on the bike. Is the only difference between the old and new RR the size and color? I looked this morning and it looks like my RR is the new one.

The previous owner said the RR got replaced because of the recall. He got it done early october.
Status: Offline
 
Reply With Quote
Old 12-10-12, 11:01   #15
Ruby Racing
BOTM Winner
 
Ruby Racing's Avatar
 
Join Date: Jan 2009
Location: Jersey, Channel Islands
Posts: 2,220
Thanks: 0
Thanked 19 Times in 17 Posts
Default

Quote:
Originally Posted by nixthewiz View Post
I just got the bike recently in october. Called my local dealer they said no oustanding recall on the bike. Is the only difference between the old and new RR the size and color? I looked this morning and it looks like my RR is the new one.

The previous owner said the RR got replaced because of the recall. He got it done early october.
That's good, sounds like it should be the new one fitted. However search for my photo comparison, this will make it a lot easier for you to tell them apart.
__________________

To read about the transformation click > Project Trixie Transformation

For comparison photo of old R/R with new improved R/R under recall of 2012 click > R/R Comparison Photos
Status: Offline
 
Reply With Quote
Old 12-10-12, 12:18   #16
nixthewiz
Junior Member
 
Join Date: Feb 2012
Location: Santa Ana
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ruby Racing View Post
That's good, sounds like it should be the new one fitted. However search for my photo comparison, this will make it a lot easier for you to tell them apart.
I just checked and yes I have the new RR and not the old one. Will have to do voltage checks now.
Status: Offline
 
Reply With Quote
Old 12-10-12, 14:00   #17
Ruby Racing
BOTM Winner
 
Ruby Racing's Avatar
 
Join Date: Jan 2009
Location: Jersey, Channel Islands
Posts: 2,220
Thanks: 0
Thanked 19 Times in 17 Posts
Default

Excellent. Hopefully you can forget about that now. Good luck.
__________________

To read about the transformation click > Project Trixie Transformation

For comparison photo of old R/R with new improved R/R under recall of 2012 click > R/R Comparison Photos
Status: Offline
 
Reply With Quote
Old 12-10-12, 19:12   #18
nixthewiz
Junior Member
 
Join Date: Feb 2012
Location: Santa Ana
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So today I took the power commander off the bike then went for a test ride. The bike ran well for the first 20 minutes or so. Then as I accelerate from low RPMs to 4-4.5k RPM the rev start increasing and decreasing by itself again. The oscillation is a lot quicker than before. As I get to 5K RPM the jerking stops.

The engine doesn't stall however. Maybe I just need to reflash a new map for aftermarket exhausts? The ECU is still running an old stock map, I have a Jardine slip on on the bike.
Status: Offline
 
Reply With Quote
Old 12-11-12, 19:58   #19
DeathStar
Senior Member
 
Join Date: Oct 2006
Location: South Florida/Fort Lauderdale FL
Posts: 990
Thanks: 0
Thanked 0 Times in 0 Posts
Default

When my regulator failed I installed a Rick's Motorsports Hot Shot regulator and have had no problems since. Been about a year or two since I installed this. Before my regulator went bad on my 2007 I had a different issue with the pickup coil on my stator and also had that replaced. Lately no problems.

I would try using the Arrow/Triumph slip on tune from your Triumph dealer for the Jardine slip-ons. This should make it run correctly.
Status: Offline
 
Reply With Quote
Old 12-12-12, 11:30   #20
nixthewiz
Junior Member
 
Join Date: Feb 2012
Location: Santa Ana
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DeathStar View Post
When my regulator failed I installed a Rick's Motorsports Hot Shot regulator and have had no problems since. Been about a year or two since I installed this. Before my regulator went bad on my 2007 I had a different issue with the pickup coil on my stator and also had that replaced. Lately no problems.

I would try using the Arrow/Triumph slip on tune from your Triumph dealer for the Jardine slip-ons. This should make it run correctly.
After a couple of more rides the jerking at 4K RPM is still there but less pronounced. If it doesn't go away in another two rides or so I'll try loading the new tune onto the ECU.
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum