R/R Test Results: Need interpretation, Bike wouldn't start then magically did... - Page 2 - Triumph675.Net Forums
Thread Tools Display Modes
post #11 of 11 Old 12-03-12, 18:22
Ruby Racing
BOTM Winner
Ruby Racing's Avatar
Join Date: Jan 2009
Location: Jersey, Channel Islands
Posts: 2,422
Thanks: 0
Thanked 32 Times in 28 Posts
Originally Posted by kevinoneill View Post
I'm more hell bent on understanding my R/R resistance results than anything else. I don't know if I'm not stating my question correctly or if no one knows a sure answer.
There is no point in understanding your results. The old R/R's are crap, as has been discussed on this forum for ever and now Triumph are finally admitting there is a problem. Just get yourself a new one before you get left stranded somewhere.

To read about the transformation click > Project Trixie Transformation

For comparison photo of old R/R with new improved R/R under recall of 2012 click > R/R Comparison Photos
Ruby Racing is offline  
Sponsored Links
Sponsored Links


Quick Reply

Register Now

In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome