What did you do to your Street Triple today? - Page 293 - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > The Street Triple 675!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-02-12, 10:48   #2921
ANZAC
Member
 
ANZAC's Avatar
 
Join Date: Apr 2010
Location: Vancouver, Washington USA
Posts: 656
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Scottyyy View Post
Attachment 34227


Sent from my iPhone using Motorcycle.com Free App
Valve check Scottyyy?

How were the settings and did you have to shim?
__________________
He has Risen
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 12-02-12, 11:30   #2922
Scottyyy
Member
 
Scottyyy's Avatar
 
Join Date: Apr 2012
Location: Williamsburg, VA
Posts: 511
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Scottyyy
Default

Quote:
Originally Posted by ANZAC View Post
Valve check Scottyyy?

How were the settings and did you have to shim?
Nah, I changed out my valve cover gasket...but I should have checked the valves too. I'm pretty sure my valves are fine, although my bike ticks a lot louder than normal lately on warm up. I'll probably just have the shop do that when I hit 24k. I don't trust myself enough. Plus, my reasoning for not doing a valve check was that I wouldn't trust myself to do the adjustment if something wasn't in spec...meaning I would have to put it back together and ride it to a shop anyway lol. My gasket was leaking and everything seems perfectly tight, so I threw a new one on there and tightened everything down properly...hopefully no more leaking. I'm really anal about my bikes and it drives me nuts when things aren't right.


Speaking of my bike being loud (probably should have learned how to check the valves)...does anyone else have a rather loud ticking sound coming from the engine when the bike is first warming up on a cold day? As you can hear by the end of my video, it goes away when it's warm enough. Yes, I have enough oil in the bike...but maybe the cold temps make the exhaust valve starve of oil until the viscosity is low enough that it can be properly lubricated?

http://www.youtube.com/watch?v=PoRM3qySB-8
Status: Offline
 
Reply With Quote
Old 12-02-12, 11:42   #2923
Tronix
Senior Member
 
Tronix's Avatar
 
Join Date: Jul 2011
Location: CT
Posts: 1,839
Thanks: 2
Thanked 7 Times in 7 Posts
Default

cam chain tensioner...
__________________
Bike: 2012 Triumph Street Triple R - My youtube channel with my videos


Car: 2012 MazdaSpeed3 JBR TIP SRI | Damond OCC | COBB AP | Stage 1 S-OTS 93
Status: Offline
 
Reply With Quote
Old 12-02-12, 14:35   #2924
Neanderthal
Senior Member
 
Neanderthal's Avatar
 
Join Date: Oct 2008
Location: Springfield, MO
Posts: 5,675
Thanks: 25
Thanked 39 Times in 30 Posts
Default

lol.... I think Scotyyy just sold the APE unit he had on hand? Not laughing at you Scott, just for you if this is the case.

I think all the 675's make some noise until warm, hard for me to tell from his video - hopefully someone more knowledgable about this will confirm if Scott has an issue or not.

Scott - nothing wrong with recognizing your limitations - a good service tech is worth establishing a working relationship with. From everything you've talked about with me - I think having a qualified second set of eyes look over your bike would be a good idea.
Status: Offline
 
Reply With Quote
Old 12-02-12, 15:15   #2925
Scottyyy
Member
 
Scottyyy's Avatar
 
Join Date: Apr 2012
Location: Williamsburg, VA
Posts: 511
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Scottyyy
Default

Quote:
Originally Posted by Neanderthal View Post
lol.... I think Scotyyy just sold the APE unit he had on hand? Not laughing at you Scott, just for you if this is the case.

I think all the 675's make some noise until warm, hard for me to tell from his video - hopefully someone more knowledgable about this will confirm if Scott has an issue or not.

Scott - nothing wrong with recognizing your limitations - a good service tech is worth establishing a working relationship with. From everything you've talked about with me - I think having a qualified second set of eyes look over your bike would be a good idea.
Lol yeah...I did sell the APE unit I had. I was really hurting for money and selling that unit right then was perfect because I didn't have enough $$ for my bike insurance that was about to be taken out. Also, if the tensioner does need replacing, I'm probably going to go with an OEM unit again just since it would be one less "aftermarket" thing on the bike for if I were to sell the bike down the road.

And yeah, if my bike needs engine work or a check up, I'm most likely going to bring it into a shop next time since I don't exactly know how the bike is supposed to be when in it's prime since I bought it pre beat-up.
Status: Offline
 
Reply With Quote
Old 12-02-12, 15:31   #2926
ANZAC
Member
 
ANZAC's Avatar
 
Join Date: Apr 2010
Location: Vancouver, Washington USA
Posts: 656
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thats the cam chain for sure

I had my valves checked at 12k and they were just fine. A couple of exhaust were just a little out of spec - so minor shimming done. Just take care of your engine and don't beat the living day lights out of it.
__________________
He has Risen
Status: Offline
 
Reply With Quote
Old 12-02-12, 16:08   #2927
Scottyyy
Member
 
Scottyyy's Avatar
 
Join Date: Apr 2012
Location: Williamsburg, VA
Posts: 511
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Scottyyy
Default

Lol awesome. Well I guess I know what I will be ordering in the near future...again haha.

On another note...I'm putting my bike back together and I seem to have found a connector without a mate? Am I going crazy or did I lose a connection somewhere? Is there supposed to be a connector under the tank not connected to something?

Click image for larger version

Name:	ImageUploadedByMO Free1354482521.707225.jpg
Views:	93
Size:	75.7 KB
ID:	34247Click image for larger version

Name:	ImageUploadedByMO Free1354482536.557027.jpg
Views:	100
Size:	81.6 KB
ID:	34248


Sent from my iPhone using Motorcycle.com Free App
__________________
My YouTube- www.youtube.com/toasttogo
My website in the making- www.motomore.net
Status: Offline
 
Reply With Quote
Old 12-02-12, 16:52   #2928
Neanderthal
Senior Member
 
Neanderthal's Avatar
 
Join Date: Oct 2008
Location: Springfield, MO
Posts: 5,675
Thanks: 25
Thanked 39 Times in 30 Posts
Default

Exercise extreme care when re-securing the tank, so as not to pinch the wiring. When you lower the tank into position, sort of wiggle it side-to-side at the same time, keeping an eye on the wiring harness. They really crammed a lot into such a small space with all the relays, ect. Also make sure your little rubber blocks are setting on the frame welds (2 of them).
Status: Offline
 
Reply With Quote
Old 12-02-12, 17:00   #2929
Scottyyy
Member
 
Scottyyy's Avatar
 
Join Date: Apr 2012
Location: Williamsburg, VA
Posts: 511
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Scottyyy
Default

Thanks for the advice. Don't worry though, I've done it a few times before already. I had to hook up my cheap signals a while back, I've had to replace the air filter, and I will be putting new signals on the bike in about a week or so again as well haha.
Status: Offline
 
Reply With Quote
Old 12-02-12, 17:05   #2930
Tronix
Senior Member
 
Tronix's Avatar
 
Join Date: Jul 2011
Location: CT
Posts: 1,839
Thanks: 2
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by Tronix View Post
cam chain tensioner...

Ya Tronix I agree its the cam chain as well, thanks for replying first. wtf
__________________
Bike: 2012 Triumph Street Triple R - My youtube channel with my videos


Car: 2012 MazdaSpeed3 JBR TIP SRI | Damond OCC | COBB AP | Stage 1 S-OTS 93
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum