Part identity help please! - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 9 Old 11-28-12, 01:48 Thread Starter
nosepickernguyen
Junior Member
 
nosepickernguyen's Avatar
 
Join Date: Nov 2012
Location: Victoria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Part identity help please!

Click image for larger version

Name:	ImageUploadedByMO Free1354085034.497025.jpg
Views:	85
Size:	134.5 KB
ID:	34190Click image for larger version

Name:	ImageUploadedByMO Free1354085060.247704.jpg
Views:	86
Size:	115.8 KB
ID:	34191
My first bike coming from a 250, love it to bits...
Does anyone know where this hat looking thingy goes?
I removed my fairings to install frane sliders and had to also undo my radiator bolts cos my engine bolt nut was forever spinning and couldn't get to it easily.

Anyhow, this hat thingy dropped when I was screwing the radiator back into place.

Any help would be great and thanks in advance!


Sent from my iPhone using Motorcycle.com Free App

Off running something, somewhere...
nosepickernguyen is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-28-12, 02:09
i NO need hellmits
Senior Member
 
i NO need hellmits's Avatar
 
Join Date: Jun 2009
Location: bay area, san rafael, CA
Posts: 1,352
Thanks: 8
Thanked 0 Times in 0 Posts
its like a little support thing for where your radiator is bolted to.

'09 black D675
Current Mods: TechSpecs, HIDs 8000K hi and low, Puig windscreen thanks to the EX-gf :(, ASV levers, CA integrated tailight, proton turn signals, British Customs Frame Sliders, Akrapovic slip on, removed exup, and Attack rear sets.
i NO need hellmits is offline  
post #3 of 9 Old 11-28-12, 02:15
i NO need hellmits
Senior Member
 
i NO need hellmits's Avatar
 
Join Date: Jun 2009
Location: bay area, san rafael, CA
Posts: 1,352
Thanks: 8
Thanked 0 Times in 0 Posts
if i recall correctly there's three of them. one at the bottom radiator where it mounts near the exhaust and 2 at the top where it mounts to the frame.

'09 black D675
Current Mods: TechSpecs, HIDs 8000K hi and low, Puig windscreen thanks to the EX-gf :(, ASV levers, CA integrated tailight, proton turn signals, British Customs Frame Sliders, Akrapovic slip on, removed exup, and Attack rear sets.
i NO need hellmits is offline  
post #4 of 9 Old 11-28-12, 02:28 Thread Starter
nosepickernguyen
Junior Member
Threadstarter Threadstarter
 
nosepickernguyen's Avatar
 
Join Date: Nov 2012
Location: Victoria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for that! Is it essential that it goes back on? I'm not sure how it fits with the bolts as the other radiator mounts are missing them as well so I don't have a guide.


Sent from my iPhone using Motorcycle.com Free App

Off running something, somewhere...
nosepickernguyen is offline  
post #5 of 9 Old 11-28-12, 10:14
tuscani451
Member
 
Join Date: Aug 2008
Location: Gilbert, AZ
Posts: 434
Thanks: 0
Thanked 0 Times in 0 Posts
I just undid my radiator and as I recall the are two "hats" per bolt (3 bolts connecting the radiator-two at the top and one at the bottom). The hats are like bushings so the bolts are not metal to metal-when placed end to end they form a channel for the bolt to go through. Idk if its essential but in the long run I'd feel better with everything as it should be. If your are still not clear you can PM me a email address and I'll send you some pics of now it's supposed to look
tuscani451 is offline  
post #6 of 9 Old 11-28-12, 10:16
tuscani451
Member
 
Join Date: Aug 2008
Location: Gilbert, AZ
Posts: 434
Thanks: 0
Thanked 0 Times in 0 Posts
****edit there may be only one hat per bolt, can't remember ATM
tuscani451 is offline  
post #7 of 9 Old 11-28-12, 22:13 Thread Starter
nosepickernguyen
Junior Member
Threadstarter Threadstarter
 
nosepickernguyen's Avatar
 
Join Date: Nov 2012
Location: Victoria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for your help guys, from your help, I worked out exactly what it does. It prevents the rubber insert from being squashed by the bolt at the top of the radiator. I would've never found this without your help THANKS!


Sent from my iPhone using Motorcycle.com Free App

Off running something, somewhere...
nosepickernguyen is offline  
post #8 of 9 Old 11-28-12, 22:14 Thread Starter
nosepickernguyen
Junior Member
Threadstarter Threadstarter
 
nosepickernguyen's Avatar
 
Join Date: Nov 2012
Location: Victoria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Exactly what you said Tuscani


Sent from my iPhone using Motorcycle.com Free App

Off running something, somewhere...
nosepickernguyen is offline  
post #9 of 9 Old 11-28-12, 22:27
tuscani451
Member
 
Join Date: Aug 2008
Location: Gilbert, AZ
Posts: 434
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by nosepickernguyen View Post
Exactly what you said Tuscani


Sent from my iPhone using Motorcycle.com Free App
Sweet! First time I got something right!! glad you got it sorted. I always end jobs with extra parts and it makes me nervous lmao
tuscani451 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome