Kinda different to key rings - Page 4 - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > General 675 discussion

General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-26-12, 17:24   #31
absowoot
Member
 
absowoot's Avatar
 
Join Date: Apr 2012
Location: MD
Posts: 218
Thanks: 1
Thanked 1 Time in 1 Post
Default

Do you have a pic with the key in the ignition? I'm curious to how big it is.

If you mounted a gopro on top of the tank, would the keyport be in the way of the view?
Status: Online
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-12, 17:26   #32
noclue90
Senior Member
 
noclue90's Avatar
 
Join Date: Feb 2012
Location: Springfield, MO
Posts: 3,299
Thanks: 2
Thanked 35 Times in 27 Posts
Default

I have it actually with video. Just need to find it.

I'm pretty sure it is in this video. Look at XXX526 YouTube Channel- The Fastest 5 Minutes in Arkansas.

Sent from my iPhone using Motorcycle.com App
__________________
2009 Triumph Street Triple- White Lightning
2007 Triumph Daytona- Golden Thunder

Last edited by noclue90; 11-26-12 at 17:32.
Status: Online
 
Reply With Quote
Old 11-26-12, 18:57   #33
Tucker2.0
Member
 
Tucker2.0's Avatar
 
Join Date: Jun 2012
Location: Hickory, NC
Posts: 504
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Tucker2.0
Default

Thats neat! seems to wobble some though...
__________________
2007 SV650S -RIP suziQ
2010 Daytona 675SE -I miss my SV, but damn that daytona!
1980 Honda cm200t (running work in progress)
Status: Offline
 
Reply With Quote
Old 11-26-12, 20:08   #34
noclue90
Senior Member
 
noclue90's Avatar
 
Join Date: Feb 2012
Location: Springfield, MO
Posts: 3,299
Thanks: 2
Thanked 35 Times in 27 Posts
Default

That's because my ignition wasn't tight. I was missing the piece that hold it in place. No fault of the Keyport.


Sent from my iPhone using Motorcycle.com App
__________________
2009 Triumph Street Triple- White Lightning
2007 Triumph Daytona- Golden Thunder
Status: Online
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum