Disabling Exup valve with TuneECU?? - Page 2 - Triumph675.Net Forums
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

Thread Tools Display Modes
post #11 of 11 Old 11-21-12, 12:17
Senior Member
Disrupt's Avatar
Join Date: May 2011
Location: Queens, NY
Posts: 2,354
Thanks: 116
Thanked 39 Times in 32 Posts
Originally Posted by chadbaldwin View Post
I don't really plan on taking it off until I get a full system, that way I can just do away with the whole thing. I'll just disable it for now. Thanks for your help.

I've already got 14K on this bike and haven't had any problems with it, guess I'm a lucky one? Or Triumph got smart with the 2012's??
Its really a hit or miss, maybe climate and weather affect it as well? who knows. People will lube it up to make sure it doesn't get stuck in place. But if your going with a full system then you could just wait it out.

1993 Mitsubishi 3000GT VR-4
2007 D675
Disrupt is offline  
Sponsored Links
Sponsored Links


Quick Reply

Register Now

In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome