Possible Wire Harness Issue - Triumph675.Net Forums
 
Thread Tools Display Modes
post #1 of 2 Old 11-17-12, 02:02 Thread Starter
Chuck B
Junior Member
 
Join Date: Aug 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Possible Wire Harness Issue

I have a 2007 675. Recently it has started cutting out on me at speed. Symtoms also include turn the key on and dash lights up but no fuel pump or starter function. Its gotten to the point it is unridable/unsafe when it does run.

I recently swapped out a used harness but can't get that one to even light up the dash with the key on. This is a track only bike and willing to go with a race harness if that is the problem.

I see there have been some TSB's but know for fact this bike has never seen a dealer. One TSB was for kill switch issues and from my research my vin falls under the range of effected bikes. Was this issue the same as my current problems/symptoms?

I do have a couple spare ECU's that I've collected and no change when I swap them in/out. Any help would be appreciated.
Chuck B is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-18-12, 02:10
MacBandit
Senior Member
 
MacBandit's Avatar
 
Join Date: Sep 2008
Location: Seattle
Posts: 10,113
Thanks: 2
Thanked 128 Times in 115 Posts
Garage
Kill switch was actually my first thought when I read the symptoms.
MacBandit is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome